summaryrefslogtreecommitdiff
path: root/app-containers/podman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
commit517343fddd94e620e94be97ae22eca4b57dc7625 (patch)
tree70b62f663c2d6f154c8808e55e827c69509918bd /app-containers/podman
parent6554f04b9a44e1ffe5d2f614201c11deed2703bd (diff)
gentoo auto-resync : 18:02:2023 - 02:09:39
Diffstat (limited to 'app-containers/podman')
-rw-r--r--app-containers/podman/Manifest2
-rw-r--r--app-containers/podman/podman-4.4.1.ebuild165
2 files changed, 167 insertions, 0 deletions
diff --git a/app-containers/podman/Manifest b/app-containers/podman/Manifest
index b25e383f17ec..262782556a9b 100644
--- a/app-containers/podman/Manifest
+++ b/app-containers/podman/Manifest
@@ -2,5 +2,7 @@ AUX podman.confd 328 BLAKE2B e03a1f7f5cec555f195bd1ca9bea050a67ccac7866bd68f0c74
AUX podman.initd 704 BLAKE2B 2fc4ffaa3b971774957ea244e05d851fa2797ec074529ea7c23bc6d7a3f597c04268d7f5580852dae4ab412629a513fed152f6a20a7ed432ef00cb96848c290c SHA512 bcf3e74a4a77bac82fc4679b3161091692b301426ecf81af7c5ea7e23ba66d15602d0cf1284f160d4179e52ae78f309ad826d9f3698dfcb78c2be2c6ac51417c
AUX podman.logrotated 85 BLAKE2B 730899f93ee354e476629276b69224cfeaaa1603b6690cac3c0cd905cd75add19179f99e26f29edbd963d5f44c38a3a2db0b5a3613dc665ab801654eac13dc2e SHA512 0136d063b15b07c41a9370ba1845c4f368ec46a7a30683b7ff7cbb0b12e5b2711c9a45329f5102af6a969e562edcec006a8de9055e43e1caf9395847d0c5ec45
DIST podman-4.3.1.tar.gz 12674902 BLAKE2B 6a6412e62004693cd734725556ee8a7082300676398fd2714c02168eaae29e56ec506755ef2a05b32c57620379ada3162607d01b641bc9197f9d9c77ff865fb8 SHA512 907dafc6481cbcb7a9b6771c3682a88d6c3b055050c0a180f9ceb985c1a3826318056b62dd6d2859a2a23eba7aad4bf26404327d5479bde98658745fa7d88efa
+DIST podman-4.4.1.tar.gz 14396828 BLAKE2B 4d5ff7d14fc3cbf5fce4b86bda81abfe2575f090820cd020b3c473aa46849dacf56986ef0a2cc1820536b2e89cddbd1f34d13c4e9338cb95bc9ac6ec25006f79 SHA512 33a22b7941f4f6715baa1cd2d5b29a4e2e95264c5239877122448f71e1408d8c393bcd2cdaef9516a580eede911c84f1cfea9d7b4c9d287a2737986fdc604e2c
EBUILD podman-4.3.1.ebuild 4782 BLAKE2B 87f1324881c4b0ed54ac37a61e811b14e7b3afe42eee5408906f958b3cde4994a7a14da6e4286a67a05655d2b47578512ba57930845806d4fed8492d9cc1e982 SHA512 921dd64bc9bec2d9c7235894cdd9cd29f3cd950a534c86d278ddb8a4bdc1eab355d92aded07c3eb79bbf48c52e652c28ad0a607959e058b0c99410d31562584d
+EBUILD podman-4.4.1.ebuild 4784 BLAKE2B d9320b651abae717d2034fb0f6ce4bb11997f3ac7e46e70cbe4e67a2392d36be7fca03a2555ee83093581eca4800f902e74f60f4e96e68693c05663fa22ef75b SHA512 8caea1ee1c67f4f59ed8d87511858420d035fa95c9251000f8a81bfd48edb2e2c85084ae759deb2b78e4c9a54215980a813d8d95e2893fa54d909065930cf345
MISC metadata.xml 1309 BLAKE2B f4e08317d4ed405eca3964b49bbc3a5b8a915245bc5e2b3912d254ee3e75e6475d44879b1118a34bd3fe7568d9be9f4747303eba821cda94d97a16d693f71b49 SHA512 ebabde88fb088061c48400021521c9b8b35f1c5af6a3bb8194f8eb1f4bad2506b77ed8ee8a30e76eb4e262c3d132e03930d23feb43a82604499a5c49ee35886f
diff --git a/app-containers/podman/podman-4.4.1.ebuild b/app-containers/podman/podman-4.4.1.ebuild
new file mode 100644
index 000000000000..587776e4cfc6
--- /dev/null
+++ b/app-containers/podman/podman-4.4.1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGIT_COMMIT="34e8f3933242f2e566bbbbf343cf69b7d506c1cf"
+
+inherit bash-completion-r1 flag-o-matic go-module tmpfiles
+
+DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
+HOMEPAGE="https://github.com/containers/podman/"
+MY_PN=podman
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://github.com/containers/podman/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+IUSE="apparmor btrfs cgroup-hybrid +fuse +init +rootless selinux"
+RESTRICT+=" test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ >=app-containers/conmon-2.0.0
+ cgroup-hybrid? ( >=app-containers/runc-1.0.0_rc6 )
+ !cgroup-hybrid? ( app-containers/crun )
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ >=app-containers/cni-plugins-0.8.6
+ sys-apps/shadow:=
+ sys-fs/lvm2
+ sys-libs/libseccomp:=
+
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( sys-fs/btrfs-progs )
+ init? ( app-containers/catatonit )
+ rootless? ( app-containers/slirp4netns )
+ selinux? ( sys-libs/libselinux:= )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}
+ fuse? ( sys-fs/fuse-overlayfs )
+ selinux? ( sec-policy/selinux-podman )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # Disable installation of python modules here, since those are
+ # installed by separate ebuilds.
+ local makefile_sed_args=(
+ -e '/^GIT_.*/d'
+ -e 's/$(GO) build/$(GO) build -v -work -x/'
+ -e 's/^\(install:.*\) install\.python$/\1/'
+ -e 's|^pkg/varlink/iopodman.go: .gopathok pkg/varlink/io.podman.varlink$|pkg/varlink/iopodman.go: pkg/varlink/io.podman.varlink|'
+ )
+
+ has_version -b '>=dev-lang/go-1.13.9' || makefile_sed_args+=(-e 's:GO111MODULE=off:GO111MODULE=on:')
+
+ sed "${makefile_sed_args[@]}" -i Makefile || die
+}
+
+src_compile() {
+ local git_commit=${EGIT_COMMIT}
+
+ # Filter unsupported linker flags
+ filter-flags '-Wl,*'
+
+ [[ -f hack/apparmor_tag.sh ]] || die
+ if use apparmor; then
+ echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
+ fi
+
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ if use btrfs; then
+ echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
+ else
+ echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die
+ fi
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ if use selinux; then
+ echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
+ fi
+
+ # Avoid this error when generating pkg/varlink/iopodman.go:
+ # cannot find package "github.com/varlink/go/varlink/idl"
+ mkdir -p _output || die
+ ln -snf ../vendor _output/src || die
+ GO111MODULE=off GOPATH=${PWD}/_output go generate ./pkg/varlink/... || die
+ rm _output/src || die
+
+ export -n GOCACHE GOPATH XDG_CACHE_HOME
+ GOBIN="${S}/bin" \
+ emake all \
+ GIT_BRANCH=master \
+ GIT_BRANCH_CLEAN=master \
+ COMMIT_NO="${git_commit}" \
+ GIT_COMMIT="${git_commit}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ insinto /etc/containers
+ newins test/registries.conf registries.conf.example
+ newins test/policy.json policy.json.example
+
+ insinto /usr/share/containers
+ doins vendor/github.com/containers/common/pkg/seccomp/seccomp.json
+
+ newconfd "${FILESDIR}"/podman.confd podman
+ newinitd "${FILESDIR}"/podman.initd podman
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/podman.logrotated" podman
+
+ dobashcomp completions/bash/*
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/*
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/*
+
+ keepdir /var/lib/containers
+}
+
+pkg_preinst() {
+ PODMAN_ROOTLESS_UPGRADE=false
+ if use rootless; then
+ has_version 'app-containers/podman[rootless]' || PODMAN_ROOTLESS_UPGRADE=true
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process podman.conf
+
+ local want_newline=false
+ if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
+ elog "You need to create the following config files:"
+ elog "/etc/containers/registries.conf"
+ elog "/etc/containers/policy.json"
+ elog "To copy over default examples, use:"
+ elog "cp /etc/containers/registries.conf{.example,}"
+ elog "cp /etc/containers/policy.json{.example,}"
+ want_newline=true
+ fi
+ if [[ ${PODMAN_ROOTLESS_UPGRADE} == true ]] ; then
+ ${want_newline} && elog ""
+ elog "For rootless operation, you need to configure subuid/subgid"
+ elog "for user running podman. In case subuid/subgid has only been"
+ elog "configured for root, run:"
+ elog "usermod --add-subuids 1065536-1131071 <user>"
+ elog "usermod --add-subgids 1065536-1131071 <user>"
+ want_newline=true
+ fi
+}