summaryrefslogtreecommitdiff
path: root/app-containers/podman-tui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-18 21:57:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-18 21:57:33 +0100
commit99c41a033e7745ed8aa9ffbf0f9e1e414e80da4a (patch)
treed7dd421828aea0525f9e8fad6380cdf6daf1ec04 /app-containers/podman-tui
parente903f5ad5c87da9f55a9c9fa0d0e5c531d25af3f (diff)
gentoo auto-resync : 18:10:2023 - 21:57:33
Diffstat (limited to 'app-containers/podman-tui')
-rw-r--r--app-containers/podman-tui/Manifest4
-rw-r--r--app-containers/podman-tui/metadata.xml17
-rw-r--r--app-containers/podman-tui/podman-tui-0.11.0.ebuild34
-rw-r--r--app-containers/podman-tui/podman-tui-9999.ebuild34
4 files changed, 89 insertions, 0 deletions
diff --git a/app-containers/podman-tui/Manifest b/app-containers/podman-tui/Manifest
new file mode 100644
index 000000000000..396b247a9b86
--- /dev/null
+++ b/app-containers/podman-tui/Manifest
@@ -0,0 +1,4 @@
+DIST podman-tui-0.11.0.tar.gz 13317542 BLAKE2B 0492799b7e61eaa75344392d824be6f41bac0b61510587cca936ec2e5f516e2513e709d739e66cd86a658fa916f61a02dbf0802a3761bab2ccb11705c3d514f3 SHA512 1b5ce216829a0f2ef345920ea908a5f721ee704bf3c7efe121e42c413edb84fb247eb32964fcd7928c734df93efd85a3c1fb5a92b0e6f3c1de3b4906fbc77fe2
+EBUILD podman-tui-0.11.0.ebuild 856 BLAKE2B 47af4841fc6d3ff7df20df273d21bf6fde9b075a4962651e11c8fd395014a5e65729a569eb52f124b8ec4f4286a88cf7e7043bba2437dfdc22ed9c40addf2166 SHA512 c9e18fbc8d2db7c7e7431349e7ae64b7555ffc5c93342adad47815f2bc73a6856946e73ae85ddbe38f7b73e73a9854262a18dbef2500e397ae0df354638e1d77
+EBUILD podman-tui-9999.ebuild 856 BLAKE2B 47af4841fc6d3ff7df20df273d21bf6fde9b075a4962651e11c8fd395014a5e65729a569eb52f124b8ec4f4286a88cf7e7043bba2437dfdc22ed9c40addf2166 SHA512 c9e18fbc8d2db7c7e7431349e7ae64b7555ffc5c93342adad47815f2bc73a6856946e73ae85ddbe38f7b73e73a9854262a18dbef2500e397ae0df354638e1d77
+MISC metadata.xml 627 BLAKE2B ec60583d8d1b2800e3635b3f84dc5763a2349bb80306360b24389107e486947dae8bf25aecd57ece7700bce16eb9b6ccaf1bf27c119b98c6dd8ee431a77f7ebb SHA512 b6f180e33ee4c85df17aa49a4768802b8d890443b63d37b3536ccada9a7c2946f365c943bc0eb5fffe6225121dfafc3935b70fce376ec9c4c662ddf8b060ceb2
diff --git a/app-containers/podman-tui/metadata.xml b/app-containers/podman-tui/metadata.xml
new file mode 100644
index 000000000000..a42c7454a3f3
--- /dev/null
+++ b/app-containers/podman-tui/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/podman-tui</remote-id>
+ <bugs-to>https://github.com/containers/podman-tui/issues</bugs-to>
+ <doc>https://github.com/containers/podman-tui/blob/main/README.md</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/app-containers/podman-tui/podman-tui-0.11.0.ebuild b/app-containers/podman-tui/podman-tui-0.11.0.ebuild
new file mode 100644
index 000000000000..58c2601964d0
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-0.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/podman-4.0.2
+"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}
diff --git a/app-containers/podman-tui/podman-tui-9999.ebuild b/app-containers/podman-tui/podman-tui-9999.ebuild
new file mode 100644
index 000000000000..58c2601964d0
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/podman-4.0.2
+"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}