summaryrefslogtreecommitdiff
path: root/app-containers/lxc-templates
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-containers/lxc-templates
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-containers/lxc-templates')
-rw-r--r--app-containers/lxc-templates/Manifest5
-rw-r--r--app-containers/lxc-templates/files/lxc-templates-3.0.1-no-cache-dir.patch12
-rw-r--r--app-containers/lxc-templates/lxc-templates-3.0.4.ebuild30
-rw-r--r--app-containers/lxc-templates/metadata.xml15
4 files changed, 62 insertions, 0 deletions
diff --git a/app-containers/lxc-templates/Manifest b/app-containers/lxc-templates/Manifest
new file mode 100644
index 000000000000..730c0c8f18b0
--- /dev/null
+++ b/app-containers/lxc-templates/Manifest
@@ -0,0 +1,5 @@
+AUX lxc-templates-3.0.1-no-cache-dir.patch 241 BLAKE2B ba9fc4fe3d663384a64600977de1c5aba413e876e6ca43464b5f5986d21d5e01729c82eb1e6ea03b087644611b9fc7bf083436e467bc69e2b3779020ca287984 SHA512 504721074d9aa4c1d71e5fb5f59c8179cbb0247b6d56d7622a68a7c55a5fdd5fa25cb92199e5400457f1bf2e4bc8e2d91d5169fb02180688c7bbca655881bdb5
+DIST lxc-templates-3.0.4.tar.gz 257015 BLAKE2B 599c0cb083cf358c8252467b3870450e754b2aa30daf8d72e07e746ce37e2fb26fecc0adf416325c9e02b1f98f5745af5985360e9494e5ed54a242a3e17330d4 SHA512 e5b628b40e7108fca858dbd9ae92495016069ff3cba7feb34e9559c7f61dfc36944a9ef441369952a988e821f8b5d883ae97b81f6eef0683a22f1f702b5b913e
+DIST lxc-templates-3.0.4.tar.gz.asc 833 BLAKE2B a125e46200cbc1bce6a721ba338b6c896098711a7454ee18a153b9e7a3d25e08ea29cf13accf25e8af085865237fe4b20d633c92d71103213a49ba7d80de0154 SHA512 1195a3d835935606af405af77d5ee629dc7b7c0f05a17c05df191f6275c8e7ebec9eb05201bbfb46060af5a36aba4f17b53122904fd10f2d8b28524f4e5b5e71
+EBUILD lxc-templates-3.0.4.ebuild 791 BLAKE2B 588d40b3c188fdba05f1331be587598a84d779e0c318c111e4e6a93ffba4fb501a52c23d377f41ff79f554ca30ca6ab0b704cea4b05f4c3c66217b6a8998ce23 SHA512 5d307a2ecec6dfd0641e38d125f7b0c44cd91482b0eeb48fa87a95581d6074a0efb6bb697b91f4ea050538b98cc234351d094e7db4f4e76de12a44ddd7459d21
+MISC metadata.xml 479 BLAKE2B 395cec3ebb2e907f2488528e5700e0b260fae721f737af2a7810ec3f150f60bec8a4ace9cdf73509db965c68e3f63e78a49880096c7815bca66755d6a22df8a3 SHA512 302efe83201442e8db88ec4893c496028918c6ac295c7f6009a351e79c9b6c8644447240bea5c0e651912b81bbd16ea042b67ff8519c8d6cefa0e38e74bc6895
diff --git a/app-containers/lxc-templates/files/lxc-templates-3.0.1-no-cache-dir.patch b/app-containers/lxc-templates/files/lxc-templates-3.0.1-no-cache-dir.patch
new file mode 100644
index 000000000000..d7e50fd3712b
--- /dev/null
+++ b/app-containers/lxc-templates/files/lxc-templates-3.0.1-no-cache-dir.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,9 +10,5 @@ EXTRA_DIST = \
+ CONTRIBUTING \
+ MAINTAINERS
+
+-install-data-local:
+- $(MKDIR_P) $(DESTDIR)$(LXCPATH)
+- $(MKDIR_P) $(DESTDIR)$(localstatedir)/cache/lxc
+-
+ ChangeLog::
+ @touch ChangeLog
diff --git a/app-containers/lxc-templates/lxc-templates-3.0.4.ebuild b/app-containers/lxc-templates/lxc-templates-3.0.4.ebuild
new file mode 100644
index 000000000000..a1f732c6c824
--- /dev/null
+++ b/app-containers/lxc-templates/lxc-templates-3.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools verify-sig
+
+DESCRIPTION="Old style template scripts for LXC"
+HOMEPAGE="https://linuxcontainers.org/ https://github.com/lxc/lxc-templates"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
+
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+RDEPEND=">=app-containers/lxc-3.0"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
+
+PATCHES=( "${FILESDIR}/${PN}-3.0.1-no-cache-dir.patch" )
+DOCS=()
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/app-containers/lxc-templates/metadata.xml b/app-containers/lxc-templates/metadata.xml
new file mode 100644
index 000000000000..7761d238525c
--- /dev/null
+++ b/app-containers/lxc-templates/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>juippis@gentoo.org</email>
+ <name>Joonas Niilola</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxc/lxc-templates</remote-id>
+ </upstream>
+</pkgmetadata>