summaryrefslogtreecommitdiff
path: root/app-containers/docker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-03 20:27:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-03 20:27:24 +0000
commit27e5574c9ed56a2633e25f7fa8f591554266a1b4 (patch)
treeeafae39b8faa55ceb7cc8100d5d03a2dfc9b7842 /app-containers/docker
parent5aede38e7304fc5c3bd8a2034b25758b15a19fa0 (diff)
gentoo auto-resync : 03:01:2023 - 20:27:24
Diffstat (limited to 'app-containers/docker')
-rw-r--r--app-containers/docker/Manifest2
-rw-r--r--app-containers/docker/docker-20.10.22.ebuild285
2 files changed, 287 insertions, 0 deletions
diff --git a/app-containers/docker/Manifest b/app-containers/docker/Manifest
index 1caca9d424a8..92be93fb3549 100644
--- a/app-containers/docker/Manifest
+++ b/app-containers/docker/Manifest
@@ -1,5 +1,7 @@
AUX 0001-Openrc-Depend-on-containerd-init-script.patch 774 BLAKE2B a7ac6f6a1e9ee88751e8e0471cd33429b8141cbea07a3a56c61eccd63c796c9135edafaf5977571a4413e5d71931aac44b5313110af94c3206e286b15394f637 SHA512 bc709b6f0dd8685fbf2404be589743f32a5f4deb24dec8ed6aeec18f0fcd1db4c5d59587209c28f62d964d78ec9ab3a3fdbb795dc4b7e3fabd00a06a002af34e
AUX ppc64-buildmode.patch 916 BLAKE2B c28a2fcfed4812f44b664dc9b24e87f3999fcb9b79b7f47c6fd5a6b024529c49ef71817d4c379c7a95832a44b9c2f45c9f7707cb580b31be18dff4ee9a110e44 SHA512 bc87464d9f3351b2791e6f86bc7f2101e652c25b99cdcc02e46e4ff18f4bfb7ffc35d338370656bde6ad09ed98805e045065012dc6a264967d26272f7de099ff
DIST docker-20.10.17.tar.gz 11182479 BLAKE2B 515c048ab6f19e256040122323f394dfa2e8f7a4aefd89e5b374355bd7907f3ba5eaae37d7ce3aed0d1add8fa025b8e5ac3c46c4dc90adf757426fd40af39dbf SHA512 1def92a4f87695b1889e482947f2bc49342ad868ee15425900b0c6f8954ba77aa2a9a8bd4fc500ba124218603aa8c7127daf7192140cace6e652a311391397c4
+DIST docker-20.10.22.tar.gz 11232083 BLAKE2B 89dea21be77beb00a5c7fde382f1621558c676c63a85cac9664ec04130b875db649b84433ef2d9a0ca9ee221bf38a46b3af85ad6bfe920cf22a15d0cac450b99 SHA512 81aec7faedced07718e3e228e999c4774fd293cedfacd272798a0057177ddca5322a701d0f644777a69b87140cd7a7194aa93a524507f202d050eb30b1a4142c
EBUILD docker-20.10.17.ebuild 8002 BLAKE2B a5967d16b5f5ad0cb674696e19451e0475ffb9edcfa9e49d9a236d68b3560fab38e2acc3952749023ff8bcdcede5babf464f21055c2c166e350ba9f9e9d748a8 SHA512 d9ad2d0cdc3aa182fbcbbfeaf596af1ffc369237a85440142c48be0f6d1a6c5b868e3a877e8d54222fa3ffe2ce9a435a5e4016398c62598fd931f4507a850206
+EBUILD docker-20.10.22.ebuild 8003 BLAKE2B b84d111643743852b97273ec45e52ac40d504f3ea1cab532814e0de04229d8063a3e43aa10c61ff67154999ecf80c12619951c72cc260019bdc4a78b0572b434 SHA512 29480340380f1668ac20c6dfbb04099dbbc33cd0a11420952400005b4a7a163049cca0d7b3a180575f1b116ac615d9386efe3426547c288ee06f00382bc453fe
MISC metadata.xml 1680 BLAKE2B 6c128f9ea99f1634e260b2f944b6560636d8501f93c3e208aff7ca8ee10199f520b187a063f9a8869130305bef8749ee1af10971658e04515e80907bc8a48be0 SHA512 913bed94f44d2093868999e8a1064c8443e4d1298b53ac065b0df0857809e93194f7650dfa1e49933022461f0adec956effff61f627838e1d0104e9d9004bf14
diff --git a/app-containers/docker/docker-20.10.22.ebuild b/app-containers/docker/docker-20.10.22.ebuild
new file mode 100644
index 000000000000..181e6b801531
--- /dev/null
+++ b/app-containers/docker/docker-20.10.22.ebuild
@@ -0,0 +1,285 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/docker/docker
+MY_PV=${PV/_/-}
+GIT_COMMIT=42c8b31499
+inherit linux-info systemd udev golang-vcs-snapshot
+
+DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/moby/moby/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc64 ~riscv ~x86"
+IUSE="apparmor aufs btrfs +cli +container-init device-mapper hardened
+overlay seccomp selinux"
+
+DEPEND="
+ acct-group/docker
+ >=dev-db/sqlite-3.7.9:3
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( >=sys-fs/btrfs-progs-3.16.1 )
+ device-mapper? ( >=sys-fs/lvm2-2.02.89[thin] )
+ seccomp? ( >=sys-libs/libseccomp-2.2.1 )
+"
+
+# https://github.com/moby/moby/blob/master/project/PACKAGERS.md#runtime-dependencies
+# https://github.com/moby/moby/blob/master/project/PACKAGERS.md#optional-dependencies
+# https://github.com/moby/moby/tree/master//hack/dockerfile/install
+# make sure docker-proxy is pinned to exact version from ^,
+# for appropriate branchch/version of course
+RDEPEND="
+ ${DEPEND}
+ >=net-firewall/iptables-1.4
+ sys-process/procps
+ >=dev-vcs/git-1.7
+ >=app-arch/xz-utils-4.9
+ dev-libs/libltdl
+ >=app-containers/containerd-1.6.6[apparmor?,btrfs?,device-mapper?,seccomp?]
+ ~app-containers/docker-proxy-0.8.0_p20220601
+ cli? ( ~app-containers/docker-cli-${PV} )
+ container-init? ( >=sys-process/tini-0.19.0[static] )
+ selinux? ( sec-policy/selinux-docker )
+"
+
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
+BDEPEND="
+ >=dev-lang/go-1.16.12
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+# tests require running dockerd as root and downloading containers
+RESTRICT="installsources strip test"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
+PATCHES=(
+ "${FILESDIR}/ppc64-buildmode.patch"
+ "${FILESDIR}/0001-Openrc-Depend-on-containerd-init-script.patch"
+)
+
+# see "contrib/check-config.sh" from upstream's sources
+CONFIG_CHECK="
+ ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
+ ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
+ ~CGROUP_NET_PRIO
+ ~KEYS
+ ~VETH ~BRIDGE ~BRIDGE_NETFILTER
+ ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE ~NETFILTER_XT_MARK
+ ~NETFILTER_NETLINK ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK ~NETFILTER_XT_MATCH_IPVS
+ ~IP_NF_NAT ~NF_NAT
+ ~POSIX_MQUEUE
+
+ ~USER_NS
+ ~SECCOMP
+ ~CGROUP_PIDS
+ ~MEMCG_SWAP
+
+ ~BLK_CGROUP ~BLK_DEV_THROTTLING
+ ~CGROUP_PERF
+ ~CGROUP_HUGETLB
+ ~NET_CLS_CGROUP
+ ~CFS_BANDWIDTH ~FAIR_GROUP_SCHED
+ ~IP_VS ~IP_VS_PROTO_TCP ~IP_VS_PROTO_UDP ~IP_VS_NFCT ~IP_VS_RR
+
+ ~VXLAN
+ ~CRYPTO ~CRYPTO_AEAD ~CRYPTO_GCM ~CRYPTO_SEQIV ~CRYPTO_GHASH ~XFRM_ALGO ~XFRM_USER
+ ~IPVLAN
+ ~MACVLAN ~DUMMY
+
+ ~OVERLAY_FS ~!OVERLAY_FS_REDIRECT_DIR
+ ~EXT4_FS_SECURITY
+ ~EXT4_FS_POSIX_ACL
+"
+
+ERROR_KEYS="CONFIG_KEYS: is mandatory"
+ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
+ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
+
+ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
+ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
+ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
+ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
+ERROR_XFRM_ALGO="CONFIG_XFRM_ALGO: is optional for secure networks"
+ERROR_XFRM_USER="CONFIG_XFRM_USER: is optional for secure networks"
+
+pkg_setup() {
+
+ if kernel_is lt 4 5; then
+ CONFIG_CHECK+="
+ ~MEMCG_KMEM
+ "
+ ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
+ fi
+
+ if kernel_is lt 4 7; then
+ CONFIG_CHECK+="
+ ~DEVPTS_MULTIPLE_INSTANCES
+ "
+ fi
+
+ if kernel_is lt 5 1; then
+ CONFIG_CHECK+="
+ ~NF_NAT_IPV4
+ ~IOSCHED_CFQ
+ ~CFQ_GROUP_IOSCHED
+ "
+ fi
+
+ if kernel_is lt 5 2; then
+ CONFIG_CHECK+="
+ ~NF_NAT_NEEDED
+ "
+ fi
+
+ if kernel_is lt 5 8; then
+ CONFIG_CHECK+="
+ ~MEMCG_SWAP_ENABLED
+ "
+ fi
+
+ if use aufs; then
+ CONFIG_CHECK+="
+ ~AUFS_FS
+ ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
+ "
+ ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs is patched to kernel instead of using standalone"
+ fi
+
+ if use btrfs; then
+ CONFIG_CHECK+="
+ ~BTRFS_FS
+ ~BTRFS_FS_POSIX_ACL
+ "
+ fi
+
+ if use device-mapper; then
+ CONFIG_CHECK+="
+ ~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
+ "
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ export DOCKER_GITCOMMIT="${GIT_COMMIT}"
+ export GOPATH="${WORKDIR}/${P}"
+ export VERSION=${PV}
+
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
+
+ # let's set up some optional features :)
+ export DOCKER_BUILDTAGS=''
+ for gd in aufs btrfs device-mapper overlay; do
+ if ! use $gd; then
+ DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
+ fi
+ done
+
+ for tag in apparmor seccomp; do
+ if use $tag; then
+ DOCKER_BUILDTAGS+=" $tag"
+ fi
+ done
+
+ if use hardened; then
+ sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
+ grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
+ sed "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
+ -i hack/make/dynbinary-daemon || die
+ grep -q -- '-fno-PIC' hack/make/dynbinary-daemon || die 'hardened sed failed'
+ fi
+
+ # build daemon
+ ./hack/make.sh dynbinary || die 'dynbinary failed'
+}
+
+src_install() {
+ dosym containerd /usr/bin/docker-containerd
+ dosym containerd-shim /usr/bin/docker-containerd-shim
+ dosym runc /usr/bin/docker-runc
+ use container-init && dosym tini /usr/bin/docker-init
+ newbin bundles/dynbinary-daemon/dockerd dockerd
+
+ newinitd contrib/init/openrc/docker.initd docker
+ newconfd contrib/init/openrc/docker.confd docker
+
+ systemd_dounit contrib/init/systemd/docker.{service,socket}
+
+ udev_dorules contrib/udev/*.rules
+
+ dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
+ dodoc -r docs/*
+
+ # note: intentionally not using "doins" so that we preserve +x bits
+ dodir /usr/share/${PN}/contrib
+ cp -R contrib/* "${ED}/usr/share/${PN}/contrib"
+}
+
+pkg_postinst() {
+ udev_reload
+
+ elog
+ elog "To use Docker, the Docker daemon must be running as root. To automatically"
+ elog "start the Docker daemon at boot:"
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog " systemctl enable docker.service"
+ else
+ elog " rc-update add docker default"
+ fi
+ elog
+ elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
+ elog ' usermod -aG docker <youruser>'
+ elog
+
+ if use device-mapper; then
+ elog " Devicemapper storage driver has been deprecated"
+ elog " It will be removed in a future release"
+ elog
+ fi
+
+ if use overlay; then
+ elog " Overlay storage driver/USEflag has been deprecated"
+ elog " in favor of overlay2 (enabled unconditionally)"
+ elog
+ fi
+
+ if has_version sys-fs/zfs; then
+ elog " ZFS storage driver is available"
+ elog " Check https://docs.docker.com/storage/storagedriver/zfs-driver for more info"
+ elog
+ fi
+
+ if use cli; then
+ ewarn "Starting with docker 20.10.2, docker has been split into"
+ ewarn "two packages upstream, so Gentoo has followed suit."
+ ewarn
+ ewarn "app-containers/docker contains the daemon and"
+ ewarn "app-containers/docker-cli contains the docker command."
+ ewarn
+ ewarn "docker currently installs docker-cli using the cli use flag."
+ ewarn
+ ewarn "This use flag is temporary, so you need to take the"
+ ewarn "following actions:"
+ ewarn
+ ewarn "First, disable the cli use flag for app-containers/docker"
+ ewarn
+ ewarn "Then, if you need docker-cli and docker on the same machine,"
+ ewarn "run the following command:"
+ ewarn
+ ewarn "# emerge --noreplace docker-cli"
+ ewarn
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}