summaryrefslogtreecommitdiff
path: root/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild')
-rw-r--r--app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild b/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
new file mode 100644
index 000000000000..7f98da207205
--- /dev/null
+++ b/app-containers/docker-bench-security/docker-bench-security-1.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Test for best practices around deploying docker containers"
+HOMEPAGE="https://github.com/docker/docker-bench-security"
+SRC_URI="https://github.com/docker/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-containers/docker-1.10"
+
+src_install() {
+dobin "${FILESDIR}/docker-bench-security"
+exeinto /usr/lib/${PN}
+doexe ${PN}.sh
+insinto /usr/lib/${PN}
+doins -r *lib.sh tests
+ dodoc -r benchmark_log.png CONTRIBUTING.md distros docker-compose.yml \
+ Dockerfile MAINTAINERS README.md
+}