summaryrefslogtreecommitdiff
path: root/app-containers/distrobox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-20 23:10:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-20 23:10:12 +0000
commit3efb3c04b80206d986b51767e6b879119d219e42 (patch)
tree1dc83a1d5ba52b1e6b3e792ea1dae4f9e7353186 /app-containers/distrobox
parentbe675f929577458bd306c90ed78b62054197c0b1 (diff)
gentoo auto-resync : 20:11:2023 - 23:10:12
Diffstat (limited to 'app-containers/distrobox')
-rw-r--r--app-containers/distrobox/Manifest4
-rw-r--r--app-containers/distrobox/distrobox-1.6.0.ebuild32
-rw-r--r--app-containers/distrobox/distrobox-9999.ebuild4
3 files changed, 37 insertions, 3 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index 558b4d82a24f..86aa1c090e61 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,4 +1,6 @@
DIST distrobox-1.5.0.2.tar.gz 5899915 BLAKE2B 2ab49e09b49dc674e0fdfd2783e4a63f12a9ec954674950c5c6f497500e1b1a6697b7350b7dfd9a246f4d3efe228c7610adde79832b0da13967b88c561186194 SHA512 41f889e8e0c0ce7019d4b1a8c638b8de8260df5c541c4068430580820094ae04b6bd8dd5a6e1a82541daf8c4f5cfed0165dc1a85e01906093d3c1a4d715e23b1
+DIST distrobox-1.6.0.tar.gz 6751299 BLAKE2B bd0edc1fa913450f033de6a78acc7631a714b6f12032f78bd4821ed9366836e94a47220da90167fb5ee0f791341d15f2027259dfc0b581b0c2d1787112b5b65f SHA512 8403349771a4f8705f88e759ff4cbffffaac1197a028a938f072b2e71b115c0cdef958b98ba9bea075feebb34330831b8eaef1aa7df6f942276a2290e4c1b6df
EBUILD distrobox-1.5.0.2.ebuild 741 BLAKE2B 25aa6f441a2134f6e2a83f2ead6083c328a4f167e8a2efe7ee4e93f35d6babb1dce8aa4b8dfdace9e681d0e0efa01f2a2fa46513fd93562f2385e0822a85013c SHA512 2a891b624fd3c6ba7e802a81d0b400ab3b00147ea62509997a0678ae6e5b52e467a33eb5a08ce0c12a376ab4be84a6ed2aabb6da8254f0ee1cb899e7bdebee34
-EBUILD distrobox-9999.ebuild 723 BLAKE2B 19fdaf771bc7ba3217245b84fd5eccc86285e106671dc44d37ffd94b4827849c68f327d80e91aae35c9ff5dca6f6a575770d96281066c6c27a7e7fde6fb95604 SHA512 ed1ab9ee3115fc409b9e2aefc2cd5063cc76d05e3fac891fe5ddea3dbb527cc576b76ff0f49e30c28e8b32e06a466968ae0b28bfd1f3f00b4613ff340b21dbfa
+EBUILD distrobox-1.6.0.ebuild 742 BLAKE2B 40dd2e4e7ab7e8f2a1f3158e386a50173d0f95c8bc0b07ebcb9fe55e2f0c1aa5649c040c966b635efd964bb24d9b14e7c9b64c85a352d0707ebbcc24ee0fe294 SHA512 489c8eb9455cab9433d0d58d9259ede871dd33d9b96937bb9ed28db98ca50b72e42411cce524ed5acb1d7b0f1cabc88492a353de7f15526a19bf755345b0139f
+EBUILD distrobox-9999.ebuild 741 BLAKE2B 25aa6f441a2134f6e2a83f2ead6083c328a4f167e8a2efe7ee4e93f35d6babb1dce8aa4b8dfdace9e681d0e0efa01f2a2fa46513fd93562f2385e0822a85013c SHA512 2a891b624fd3c6ba7e802a81d0b400ab3b00147ea62509997a0678ae6e5b52e467a33eb5a08ce0c12a376ab4be84a6ed2aabb6da8254f0ee1cb899e7bdebee34
MISC metadata.xml 957 BLAKE2B a02f57f2c65a9241edbc6a1e99170712ceca000977c2271ba51c5311e7718471585ea791ed8c978a86a961d02450623c05b5f9006d4386be2130df08341b0e49 SHA512 65f455bcfd246a8de0084e1534dc85f09435f1fad2590ba87dda0bed90d8fa976d3fad2142b2006a596e713d3d91f0d3d3156017cebacf9dc7883596edb0740f
diff --git a/app-containers/distrobox/distrobox-1.6.0.ebuild b/app-containers/distrobox/distrobox-1.6.0.ebuild
new file mode 100644
index 000000000000..cf9ea7ec09d5
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}
diff --git a/app-containers/distrobox/distrobox-9999.ebuild b/app-containers/distrobox/distrobox-9999.ebuild
index f3fc5a365796..123c5f82a360 100644
--- a/app-containers/distrobox/distrobox-9999.ebuild
+++ b/app-containers/distrobox/distrobox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == *9999* ]] ; then
else
SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
fi
LICENSE="GPL-3" # GPL-3.0-only !