summaryrefslogtreecommitdiff
path: root/app-containers/distrobox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 01:49:56 +0000
commit30be4d7d2806b014770312920fcda743d4dc67d0 (patch)
tree229c7337dfd56654c52009367273c078b016a25c /app-containers/distrobox
parentf287ecad888abdeb38e617d0485de282cd6819db (diff)
gentoo auto-resync : 20:12:2022 - 01:49:56
Diffstat (limited to 'app-containers/distrobox')
-rw-r--r--app-containers/distrobox/Manifest2
-rw-r--r--app-containers/distrobox/distrobox-1.4.2.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index 2c55efa77295..cd7066bdc774 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,4 +1,6 @@
DIST distrobox-1.4.1.tar.gz 231405 BLAKE2B 920fc2ccf20ad2b6af2a3ea3dfe5c209cd779d6490e6fb95110af5e74ce56354aa264f413c070a6814253a5c51e82be110b8fc86e536a4ae0881fa22afc16630 SHA512 6cee6b734bf22e678529b93f15cdf98f09506642ef5e204ae73590c29a85e205a16715588c9e49b1c39b71023ea906565078e9c2c1f6368df885d20bf37136e2
+DIST distrobox-1.4.2.1.tar.gz 235019 BLAKE2B dd512b183763a2e4c7e2b495bb50cc3fc3d764c48ce902b83e0b543587b60b458c6b9ae937057bfc91860dc415f9ad68fb648cf06faeeb56d0a4c27180e4c2e0 SHA512 d3bc1de91bf33b7ac500c0ae471feb28c9b1efdef6878bf1aed50ef394f69d2d36f99296f0a8182b139d9339558720b891f7dc1249a7f91c883c00bac5597283
EBUILD distrobox-1.4.1.ebuild 723 BLAKE2B 19fdaf771bc7ba3217245b84fd5eccc86285e106671dc44d37ffd94b4827849c68f327d80e91aae35c9ff5dca6f6a575770d96281066c6c27a7e7fde6fb95604 SHA512 ed1ab9ee3115fc409b9e2aefc2cd5063cc76d05e3fac891fe5ddea3dbb527cc576b76ff0f49e30c28e8b32e06a466968ae0b28bfd1f3f00b4613ff340b21dbfa
+EBUILD distrobox-1.4.2.1.ebuild 723 BLAKE2B 19fdaf771bc7ba3217245b84fd5eccc86285e106671dc44d37ffd94b4827849c68f327d80e91aae35c9ff5dca6f6a575770d96281066c6c27a7e7fde6fb95604 SHA512 ed1ab9ee3115fc409b9e2aefc2cd5063cc76d05e3fac891fe5ddea3dbb527cc576b76ff0f49e30c28e8b32e06a466968ae0b28bfd1f3f00b4613ff340b21dbfa
EBUILD distrobox-9999.ebuild 723 BLAKE2B 19fdaf771bc7ba3217245b84fd5eccc86285e106671dc44d37ffd94b4827849c68f327d80e91aae35c9ff5dca6f6a575770d96281066c6c27a7e7fde6fb95604 SHA512 ed1ab9ee3115fc409b9e2aefc2cd5063cc76d05e3fac891fe5ddea3dbb527cc576b76ff0f49e30c28e8b32e06a466968ae0b28bfd1f3f00b4613ff340b21dbfa
MISC metadata.xml 957 BLAKE2B a02f57f2c65a9241edbc6a1e99170712ceca000977c2271ba51c5311e7718471585ea791ed8c978a86a961d02450623c05b5f9006d4386be2130df08341b0e49 SHA512 65f455bcfd246a8de0084e1534dc85f09435f1fad2590ba87dda0bed90d8fa976d3fad2142b2006a596e713d3d91f0d3d3156017cebacf9dc7883596edb0740f
diff --git a/app-containers/distrobox/distrobox-1.4.2.1.ebuild b/app-containers/distrobox/distrobox-1.4.2.1.ebuild
new file mode 100644
index 000000000000..f3fc5a365796
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.4.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}