summaryrefslogtreecommitdiff
path: root/app-containers/distrobox/distrobox-1.7.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /app-containers/distrobox/distrobox-1.7.2.1.ebuild
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'app-containers/distrobox/distrobox-1.7.2.1.ebuild')
-rw-r--r--app-containers/distrobox/distrobox-1.7.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/distrobox/distrobox-1.7.2.1.ebuild b/app-containers/distrobox/distrobox-1.7.2.1.ebuild
new file mode 100644
index 000000000000..0a328c47011d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}