summaryrefslogtreecommitdiff
path: root/app-containers/crun
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-01 19:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-01 19:26:48 +0000
commit93d7658008fb431ae469d5b6356fd53390998561 (patch)
tree0ba7ce8abb6392056459995442ae0e9e706c9364 /app-containers/crun
parentc172714c13cbad928c88d1a98d01eeaa157b3504 (diff)
gentoo auto-resync : 01:03:2023 - 19:26:48
Diffstat (limited to 'app-containers/crun')
-rw-r--r--app-containers/crun/Manifest2
-rw-r--r--app-containers/crun/crun-1.8.1.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/app-containers/crun/Manifest b/app-containers/crun/Manifest
index 50cf321deccd..d96812ac9250 100644
--- a/app-containers/crun/Manifest
+++ b/app-containers/crun/Manifest
@@ -1,6 +1,8 @@
AUX crun-1.4.5-glibc-2.36.patch 2631 BLAKE2B 6f37b02f2c87d056af84c1dc146ba5b9915ae95492aea6d1d2f6e708b70bc37d2d48d666fb7d63ce2a07c594dc76cea3dd6892b7356cea56a3568d93d9f5a7d1 SHA512 1f54d6c1bfd3e4fcbd39e0c4651d43d21e7902309d3b844acdb6f908ea3b3d364b01f90b6ecb81bd98ce8f0f035061399fea781a8e76acf07ce32824b72960cc
DIST crun-1.4.4.tar.xz 877892 BLAKE2B 57e48c0a229db3f54212177cef3fdb3f59b4bb1d1cc865da956f026a35837d839489bd126f880d7a9ceb18f5cffbf0e32ac9ae59a4cd39c34e3aff5b32c0559a SHA512 1756dccf6509457a5dc114d43c4f4e99258a20c3437dfe06016d080989c5d3035f5735d62d18ab537b660ec36de04df369a2582745baf4ab680af367a19830fd
DIST crun-1.4.5.tar.xz 879044 BLAKE2B c80cae28c23140086682493a7dddb40640491e3ea827f0a7376d9be12570111d056022f50b8d7c574ca07790753d20de2314db5b89463994c4fffbc7576c372d SHA512 9f288279615fdf587018c465047fc8793daae280ab864bf9046994983239129d50f2eb89cac9b092e5cdc49a10f3523ab403a3f0e7451f7536b79f651a355153
+DIST crun-1.8.1.tar.xz 692152 BLAKE2B b5dce1a454641221c591f50ac8519d4e9e9d892ea56232fa3fc9916934c19eba5853019238b1837cd5fb61f0dec5e0e6a11c02f628bece3b69c9c4f5750addae SHA512 6230b378f4746aff1d53f3ed797229b2056ece76e8e5b22d6f5f7b42e6042c6aff5294298f3cfd1293b4a87371dfa58cc69e57455e20948abd7269059ad39042
EBUILD crun-1.4.4.ebuild 1624 BLAKE2B eaea46a12c688834557c9f7c18ca10fd16123f2dd7970b49c70a3f484a1e7129db2e86f2d5ce9764d9a9987b7edac72f21e75ceb68857199281737ee03ccb581 SHA512 d06c536c71b70c356a7f3ea7b90041abcd7a8d9cd6ab9e9fae1b8ade416520bc9f266a804cd2dae61e0057c092fa2d4f7de492311a13344b834ecc070317c558
EBUILD crun-1.4.5.ebuild 1804 BLAKE2B a3fead6bce9658b926cf0f69a57c47c81682d79bea3ee6436e28ba238ca3735325b7f956df4400e4107677260a99843dbb27fcdb4b3533b51c48920ffb3ef025 SHA512 ca1e53476cf2fdd2c0a64cb579def04826c936faa69066d22c89987677314d209e4271586e5eb02641a07f47b45d410936ead2e2a80d253ad3b9b8f3f309568c
+EBUILD crun-1.8.1.ebuild 1601 BLAKE2B 59de7ce55a9eecb3afe526cbab152e2c649667ebe44d32abf17d02fbcf4cdd5577456bdc86f2754ef948da16fa37dff1deb0cd83d667e862e1e4e057d8013a50 SHA512 cf10d10b22a82ba7cf6ac015338330f007a9dd8cb04577282f94d30c99aa8d5819265b0ca74bffb69157bb089b46617a3d73fc48c77ae3c06cc1bc5d53af78bd
MISC metadata.xml 1300 BLAKE2B a0ae27420fca097e4e7b5e983de3b76fef43bf13887bd5fe903da14e20c2f0ebd2fc273dae74e32e28c2768b5f8d6e5e6c8b4c9f07ca6d47e41902621173a167 SHA512 1699a89a01de32b580bc74bc747430ef7b1a6284b2f459b4041b22de0efbebda45778803deb512a61806ed8e2998b141caefb7830acafc68d42ce4343b193dd6
diff --git a/app-containers/crun/crun-1.8.1.ebuild b/app-containers/crun/crun-1.8.1.ebuild
new file mode 100644
index 000000000000..4f443f5c280e
--- /dev/null
+++ b/app-containers/crun/crun-1.8.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# Can drop autotools/eautoreconf after next release & glibc patch gone
+inherit autotools python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv"
+IUSE="+bpf +caps criu +seccomp selinux systemd static-libs"
+
+DEPEND="
+ dev-libs/libgcrypt:=
+ dev-libs/yajl:=
+ sys-kernel/linux-headers
+ caps? ( sys-libs/libcap )
+ criu? ( >=sys-process/criu-3.15 )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-container )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable bpf)
+ $(use_enable caps)
+ $(use_enable criu)
+ $(use_enable seccomp)
+ $(use_enable systemd)
+ $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake git-version.h
+ emake -C libocispec
+ emake crun
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ doman crun.1
+ einstalldocs
+}