summaryrefslogtreecommitdiff
path: root/app-containers/cri-tools/cri-tools-1.24.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-containers/cri-tools/cri-tools-1.24.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-containers/cri-tools/cri-tools-1.24.0.ebuild')
-rw-r--r--app-containers/cri-tools/cri-tools-1.24.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/cri-tools/cri-tools-1.24.0.ebuild b/app-containers/cri-tools/cri-tools-1.24.0.ebuild
new file mode 100644
index 000000000000..0a580bdda110
--- /dev/null
+++ b/app-containers/cri-tools/cri-tools-1.24.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
+HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
+SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go"
+
+RESTRICT+=" test"
+
+src_compile() {
+ emake VERSION="${PV}"
+ ./build/bin/crictl completion bash > "${PN}.bash" || die
+ ./build/bin/crictl completion zsh > "${PN}.zsh" || die
+}
+
+src_install() {
+ dobin ./build/bin/crictl
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
+}