summaryrefslogtreecommitdiff
path: root/app-containers/cri-o
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 22:19:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 22:19:54 +0100
commit71f9cc21aab4168093940b3d2e267444d712bff5 (patch)
tree15406e14be0cd3cfbafe191468b8825b3ccc1855 /app-containers/cri-o
parent312456186919deebd1ea3b34b9e26b1e15ebd5b6 (diff)
gentoo auto-resync : 03:09:2022 - 22:19:54
Diffstat (limited to 'app-containers/cri-o')
-rw-r--r--app-containers/cri-o/Manifest2
-rw-r--r--app-containers/cri-o/cri-o-1.25.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/app-containers/cri-o/Manifest b/app-containers/cri-o/Manifest
index e8c961cc2cb2..f096f0561123 100644
--- a/app-containers/cri-o/Manifest
+++ b/app-containers/cri-o/Manifest
@@ -1,5 +1,7 @@
AUX cri-o.logrotated 81 BLAKE2B f17d96920c3e9bbfe68a38fcae49be999c0edcea085ebbc1f09585284c5b7930c185d5cd0ef6c2f7de5db2a6af80355518628a050c1cb0639ccf3b53c6c338da SHA512 1115228546a696eeebeb6d4b3e5c3152af0c99a2559097fc5829d8b416d979c457b4b1789e0120054babf57f585d3f63cbe49949d40417ae7aab613184bf4516
AUX crio.initd 846 BLAKE2B 844400d3cd706d4f78616edb3c8a50a9819ee21aecc7fc33f7d3d00871fde86b59e4b604ccc7cdb0058b10ccd28277f19dbdce34c83b2529c14e063126318617 SHA512 29561e95398975748236217bbd9df64997f6e3de6c0555d007306bd0535895a648368385a13079eb7d52c06249a91980523a73b6563e86d0575d9cd9c3fa4ee9
DIST cri-o-1.24.1.tar.gz 15943809 BLAKE2B 13840967b7555e680652cdfe71e358fee5afcfbdbc28771960a5e28c88d6242909a595212559b7967c05cfc7cf9921d6d227b810a26bdc66cb75ffed917bcb23 SHA512 899efb61c70be3a0e950dc239245e1a4dca66e2130d8b355a7ad73c1e91088a2d42c6a4cc05f879cc6a1252d40294e9a8845fd2b110148a05a9d63f61077c498
+DIST cri-o-1.25.0.tar.gz 27673668 BLAKE2B 5231f1b00781233ddf82827a580100055fefb97e768d871a845506ee28ebc122f20f6c8dff64b9dd8d991ed6ed761a72e96d607354f7e8d4182daff36ef3c253 SHA512 783c2f019ef65079dbb838e58acde5a24bda282ba8298d7b95491356e46fc208a14bcc4c65e3183001f0fb275d8ec5d7b5c795300e6424096f84fb9130721cba
EBUILD cri-o-1.24.1.ebuild 2722 BLAKE2B 9533ffcd06f6ffe7a66e379f6a240f68ba87dd387a785f2e51e513795c0823148f0ba6e20b95dea22bed160df6ed04259c3bd32f632f3d6b5a44b1fde30b8345 SHA512 11ab7eb74a3c32c6b0ae2ba94b5c082d1079a20fecd47574948aa8c2ad9fa6b5976e8b2de06250090ee0e2d578fe7807956066e5796be1703b736dcc81d048ca
+EBUILD cri-o-1.25.0.ebuild 2722 BLAKE2B a82323f0abbb66eec87d490128f12ee02e61e818232c5fa3965c5e1d9c20998834d4fd94bca80c435371a34bff2d2c69fde844302bf4ac038cf8bf39a01b5e3e SHA512 e7a3684fd2d1f2396722e8dc89380b575f4f53d70c2194f4d300b24b8601ef6d2b59caa1b3b87b5f5c83e87c6520a938715c07b773ee428eb329e15a91bf18b4
MISC metadata.xml 908 BLAKE2B ff6e1663f563dff74dbdeeb5d5c778a70fe2395ff0c0836e31b538f0009215a74946384a1429f2cf8e65bccc26d4b357233f1aab1a2c70ca3f544653d79cf999 SHA512 0fe5ad9f9f1c3b7386f361febbedddb690fcf83145f80da05d77be72bf04f84d9106d46ff6962ed6cc99d7b12f3792263eb7b1711763a2cd2f8a7dac08ed5c09
diff --git a/app-containers/cri-o/cri-o-1.25.0.ebuild b/app-containers/cri-o/cri-o-1.25.0.ebuild
new file mode 100644
index 000000000000..60e59d76e3fe
--- /dev/null
+++ b/app-containers/cri-o/cri-o-1.25.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT=315a0cb5b0abd15619384d7da7f3941714afcb8e
+
+inherit go-module
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-containers/conmon
+ app-containers/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ app-containers/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}
+ !<app-containers/podman-1.3.2-r1"
+
+src_prepare() {
+ default
+
+ sed -e '/^export GOPROXY=/d' \
+ -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ emake all \
+ GOBIN="${S}/bin" \
+ GO_BUILD="go build ${GOFLAGS}" \
+ GO_MD2MAN="$(which go-md2man)"
+}
+
+src_install() {
+ emake install install.config install.systemd \
+ DESTDIR="${D}" \
+ GO_MD2MAN="$(which go-md2man)" \
+ PREFIX="${D}${EPREFIX}/usr"
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+}