summaryrefslogtreecommitdiff
path: root/app-containers/cosign/cosign-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 06:04:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 06:04:07 +0000
commit27ecae7b5eb4c80903720ae76a54a68af3447c31 (patch)
tree90b91404883f7c53646987409a6636aa44549bd9 /app-containers/cosign/cosign-2.0.0.ebuild
parent71e206c31e948709a88fafc342bd2d8695942aa5 (diff)
gentoo auto-resync : 10:03:2023 - 06:04:07
Diffstat (limited to 'app-containers/cosign/cosign-2.0.0.ebuild')
-rw-r--r--app-containers/cosign/cosign-2.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-containers/cosign/cosign-2.0.0.ebuild b/app-containers/cosign/cosign-2.0.0.ebuild
new file mode 100644
index 000000000000..f9229084772b
--- /dev/null
+++ b/app-containers/cosign/cosign-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_HASH=d6b9001f8e6ed745fb845849d623274c897d55f2
+inherit go-module
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+dodoc CHANGELOG.md
+}