summaryrefslogtreecommitdiff
path: root/app-containers/containers-image
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 05:16:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 05:16:15 +0100
commit67ff4e881df5f5a1482662d6aba4680f82d12197 (patch)
tree4b24e048c6a713f514fc5397b5eb8418a7fa490e /app-containers/containers-image
parentdcd08467271c676e143c6c967faf8580fae7ca77 (diff)
gentoo auto-resync : 22:09:2023 - 05:16:14
Diffstat (limited to 'app-containers/containers-image')
-rw-r--r--app-containers/containers-image/Manifest5
-rw-r--r--app-containers/containers-image/containers-image-5.28.0.ebuild45
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild45
-rw-r--r--app-containers/containers-image/files/fix-warnings.patch14
-rw-r--r--app-containers/containers-image/metadata.xml17
5 files changed, 126 insertions, 0 deletions
diff --git a/app-containers/containers-image/Manifest b/app-containers/containers-image/Manifest
new file mode 100644
index 000000000000..afc95688396f
--- /dev/null
+++ b/app-containers/containers-image/Manifest
@@ -0,0 +1,5 @@
+AUX fix-warnings.patch 397 BLAKE2B a5922e061c825e25398fc3fccdf683abf8331b065337ff240227478d7d3ef5398957d56a430c0b04aa823033b56653e87c8186065e5898818e75310451b347e0 SHA512 a96ab3fea76be4751d6dc3893b4272b063c854503e1a65b4501819a5925f3911c285fbfb4ee6827795a41c696015cc06f446e4ddb1318e21cf0141e15804833e
+DIST containers-image-5.28.0.tar.gz 688100 BLAKE2B 0cee8be579bd11eb0524590d8afe16b6ef863d7adfd74db51b68385142804c8096fec3f2a492e0d5a5021eba9edc91219b327138635aaa329c6ef7d0c01129c8 SHA512 0b76539e04016f5f1067c576a877ace475f25d0f0840fc969606601105a8a7f0e242cc054b0a2cfb6f1b751d850734360a524c78563fdf2330c8ae8c11bba1cf
+EBUILD containers-image-5.28.0.ebuild 794 BLAKE2B 68a7bbe15e21f49a15ba685c6e30374dc3ed15309ef600537d54d28d63046b2289ce76cb44f170ae52303e7b2553a88265468630a7a697aa32d8d3945c2a5fa7 SHA512 7552a9e886c485aba8451c25695a79be561fbed5dcf0e171424b2d2dfc605d0b93853d7161d481e2f8877066c60b07c084fc3ef4f25f9cac64657ef2f5471b52
+EBUILD containers-image-9999.ebuild 794 BLAKE2B 68a7bbe15e21f49a15ba685c6e30374dc3ed15309ef600537d54d28d63046b2289ce76cb44f170ae52303e7b2553a88265468630a7a697aa32d8d3945c2a5fa7 SHA512 7552a9e886c485aba8451c25695a79be561fbed5dcf0e171424b2d2dfc605d0b93853d7161d481e2f8877066c60b07c084fc3ef4f25f9cac64657ef2f5471b52
+MISC metadata.xml 632 BLAKE2B c48672fb67a353cb54f27fb541d91899a27b913ac6036000d65f8ee0356aad9ea9a7e796aa239b3b6fa2b3e08cd9890a142e20ef46e6f5bc5577c6d82cdd6f1e SHA512 a989fa8d4076d55b36e2727250f0c622dd821791cd55b650c585e15689d21da8e1158c869348b6c7e772db8729b84c2e93ab10918b9e9b8a646b639c2959852c
diff --git a/app-containers/containers-image/containers-image-5.28.0.ebuild b/app-containers/containers-image/containers-image-5.28.0.ebuild
new file mode 100644
index 000000000000..a29e5e602b78
--- /dev/null
+++ b/app-containers/containers-image/containers-image-5.28.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/fix-warnings.patch"
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ emake docs
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
new file mode 100644
index 000000000000..a29e5e602b78
--- /dev/null
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/fix-warnings.patch"
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ emake docs
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/files/fix-warnings.patch b/app-containers/containers-image/files/fix-warnings.patch
new file mode 100644
index 000000000000..c68cffa8584b
--- /dev/null
+++ b/app-containers/containers-image/files/fix-warnings.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,2 @@
+
+-GOBIN := $(shell go env GOBIN)
+-ifeq ($(GOBIN),)
+-GOBIN := $(shell go env GOPATH)/bin
+-endif
+-
+ # when cross compiling _for_ a Darwin or windows host, then we must use openpgp
+@@ -17,3 +12,2 @@
+
+-PACKAGES := $(shell GO111MODULE=on go list $(BUILDFLAGS) ./...)
+ SOURCE_DIRS = $(shell echo $(PACKAGES) | awk 'BEGIN{FS="/"; RS=" "}{print $$4}' | uniq)
diff --git a/app-containers/containers-image/metadata.xml b/app-containers/containers-image/metadata.xml
new file mode 100644
index 000000000000..4296f17b57ba
--- /dev/null
+++ b/app-containers/containers-image/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/image</remote-id>
+ <bugs-to>https://github.com/containers/image/issues</bugs-to>
+ <doc>https://github.com/containers/image/blob/main/README.md</doc>
+ </upstream>
+</pkgmetadata>