summaryrefslogtreecommitdiff
path: root/app-containers/containers-image/containers-image-5.30.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-19 06:50:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-19 06:50:06 +0000
commit06617f385b21ef2262c88f17869c15c424e67d21 (patch)
tree3f6ea6fba81d85145b37641fb93140f3c70f57c9 /app-containers/containers-image/containers-image-5.30.0.ebuild
parent2c18b7f7fb2885d27960657c60906ef0bac0681e (diff)
gentoo auto-resync : 19:03:2024 - 06:50:06
Diffstat (limited to 'app-containers/containers-image/containers-image-5.30.0.ebuild')
-rw-r--r--app-containers/containers-image/containers-image-5.30.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-containers/containers-image/containers-image-5.30.0.ebuild b/app-containers/containers-image/containers-image-5.30.0.ebuild
new file mode 100644
index 000000000000..f4507f8d00cf
--- /dev/null
+++ b/app-containers/containers-image/containers-image-5.30.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# https://github.com/gentoo/gentoo/pull/35012#discussion_r1473740969
+RESTRICT='test'
+BDEPEND=">=dev-go/go-md2man-2.0.3"
+PATCHES=(
+ "${FILESDIR}"/fix-warnings.patch
+)
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}