summaryrefslogtreecommitdiff
path: root/app-containers/cni-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
commita6266c63b23ed0ee16865627ca53e4f5353f0a5c (patch)
tree6ed71ecc485e9c4903818db305f6ebee454a38db /app-containers/cni-plugins
parent1fd4e372381e1318aae1b7d3338c04156e5da974 (diff)
gentoo auto-resync : 17:07:2022 - 02:30:06
Diffstat (limited to 'app-containers/cni-plugins')
-rw-r--r--app-containers/cni-plugins/Manifest6
-rw-r--r--app-containers/cni-plugins/cni-plugins-0.9.1.ebuild32
-rw-r--r--app-containers/cni-plugins/cni-plugins-1.1.1.ebuild33
-rw-r--r--app-containers/cni-plugins/files/cni-dhcp.initd20
-rw-r--r--app-containers/cni-plugins/metadata.xml11
5 files changed, 102 insertions, 0 deletions
diff --git a/app-containers/cni-plugins/Manifest b/app-containers/cni-plugins/Manifest
new file mode 100644
index 000000000000..409a2616f31d
--- /dev/null
+++ b/app-containers/cni-plugins/Manifest
@@ -0,0 +1,6 @@
+AUX cni-dhcp.initd 376 BLAKE2B 5fe40f28773ffbb12416b40e3813578d28787e9ee26ec4a62b2d3e834920f43fedd0bc985bb412c9576c438367429c835b6099f78f017932b6cdff9341e3f356 SHA512 3475f7c6966b9afac6be52c705286b235a59847748aad5c602162589d4ee1193acffc5965c9130c311e318d06f62a3930d5eb1a70b118a63270f4241f8c4fce8
+DIST cni-plugins-0.9.1.tar.gz 2703099 BLAKE2B 878f476e62f12020b39d33a79723fe246b34d80705d3a336573401743392adca9a57b196d6d191b4a6f281110f47ecbb1525aacd91cd488bea61c7aaed12a6ef SHA512 24e8fcedbff2ae7a83aa96085b546b164de6a0884d593e3b5386e9d2de3c4d9a215db9e9405332020cc45c371709a32b600e263e4f8dee62c51adafdc0180f24
+DIST cni-plugins-1.1.1.tar.gz 3076064 BLAKE2B 2fd70260995e423d2b4ac3a8d2135074baffe5d36177d5e1e5a9ce146f6d2ecfeb3b843de62e43f863085ff965be4160cf5f4cae892d3c59070ef390409ef3c9 SHA512 03da31caee5f9595abf65d4a551984b995bc18c5e97409549f08997c5a6a2b41a8950144f8a5b4f810cb401ddbe312232d2be76ec977acf8108eb490786b1817
+EBUILD cni-plugins-0.9.1.ebuild 948 BLAKE2B 340be886eb779358a8a7f6fe7a94bbc45dd53e51b65f729bfc1eb614e2a8e7db1b7b19622b75b8fb382882ce6d4915ab1b9a3282b7cc76de7efbfd07cea40fc6 SHA512 0a25abd6833e459576afdc3174afe57491a86b5eff6aba6d718db439af1acd983ccc769619448683ae42b57a561a785599146a9f6423dbae7395c625819739cd
+EBUILD cni-plugins-1.1.1.ebuild 1026 BLAKE2B 43b5cfb19b0f5413ae5a34168c29746cd9994a29f75b062189ce7b21fca28c504509a7778f302355d6ab9feb4717111a78adefd93a5a401fedb439f9c16c29bb SHA512 8a177cfb045ccb108abde16e90f61bda39bec7227e9161e8957f37c8049004cad4628b5dcc82bb98e789f56856d38e9c27628a57d473b4ad843329072470362d
+MISC metadata.xml 351 BLAKE2B 3565fe13764f828aed1288724a2939be57e523e0d0a9ccf3c091715e6f1e102155a7fa28191a3c87d669d51a0fa087a89587d83fe6c4747d5d9b31da11c1578c SHA512 6cfe3058d20387245c2f4823c7629d464115783e3c9ed1e45769d6e13f2f35f94656c66c0b1572f8eb229e6bf43510dbc35d117d6a3379e15b5b6ababc077856
diff --git a/app-containers/cni-plugins/cni-plugins-0.9.1.ebuild b/app-containers/cni-plugins/cni-plugins-0.9.1.ebuild
new file mode 100644
index 000000000000..5d4529918862
--- /dev/null
+++ b/app-containers/cni-plugins/cni-plugins-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module linux-info
+
+DESCRIPTION="Standard networking plugins for container networking"
+HOMEPAGE="https://github.com/containernetworking/plugins"
+SRC_URI="https://github.com/containernetworking/plugins/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~ppc64 ~riscv"
+IUSE="hardened"
+
+CONFIG_CHECK="~BRIDGE_VLAN_FILTERING"
+S="${WORKDIR}/plugins-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" ./build_linux.sh || die
+}
+
+src_install() {
+ exeinto /opt/cni/bin
+ doexe bin/*
+ dodoc README.md
+ local i
+ for i in plugins/{meta/{bandwidth,firewall,flannel,portmap,sbr,tuning},main/{bridge,host-device,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local,static},sample}; do
+ newdoc README.md ${i##*/}.README.md
+ done
+ newinitd "${FILESDIR}"/cni-dhcp.initd cni-dhcp
+}
diff --git a/app-containers/cni-plugins/cni-plugins-1.1.1.ebuild b/app-containers/cni-plugins/cni-plugins-1.1.1.ebuild
new file mode 100644
index 000000000000..963ca87f9d33
--- /dev/null
+++ b/app-containers/cni-plugins/cni-plugins-1.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info systemd
+
+DESCRIPTION="Standard networking plugins for container networking"
+HOMEPAGE="https://github.com/containernetworking/plugins"
+SRC_URI="https://github.com/containernetworking/plugins/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+IUSE="hardened"
+
+CONFIG_CHECK="~BRIDGE_VLAN_FILTERING"
+S="${WORKDIR}/plugins-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" ./build_linux.sh || die
+}
+
+src_install() {
+ exeinto /opt/cni/bin
+ doexe bin/*
+ dodoc README.md
+ local i
+ for i in plugins/{meta/{bandwidth,firewall,flannel,portmap,sbr,tuning},main/{bridge,host-device,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local,static},sample}; do
+ newdoc README.md ${i##*/}.README.md
+ done
+ systemd_dounit plugins/ipam/dhcp/systemd/cni-dhcp.{service,socket}
+ newinitd "${FILESDIR}"/cni-dhcp.initd cni-dhcp
+}
diff --git a/app-containers/cni-plugins/files/cni-dhcp.initd b/app-containers/cni-plugins/files/cni-dhcp.initd
new file mode 100644
index 000000000000..26b838c516bd
--- /dev/null
+++ b/app-containers/cni-plugins/files/cni-dhcp.initd
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+
+name="CNI-DHCP"
+description="virtual dhcp server for containers"
+command="/opt/cni/bin/dhcp"
+command_args="daemon"
+command_background=true
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ need net
+}
+
+stop_post() {
+ if [ -e /run/cni/dhcp.sock ]; then
+ ebegin "Cleaning socket for ${name}"
+ rm -f /run/cni/dhcp.sock
+ eend $? "Failed to cleanup socket"
+ fi
+}
diff --git a/app-containers/cni-plugins/metadata.xml b/app-containers/cni-plugins/metadata.xml
new file mode 100644
index 000000000000..8359d9316145
--- /dev/null
+++ b/app-containers/cni-plugins/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containernetworking/plugins</remote-id>
+ </upstream>
+</pkgmetadata>