summaryrefslogtreecommitdiff
path: root/app-containers/catatonit/catatonit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-27 11:30:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-27 11:30:42 +0100
commitddb6fbc11e863756a24e1dc866c63dec00eac6fa (patch)
tree697bafc13819641c0cb81d469945e2a773adca86 /app-containers/catatonit/catatonit-9999.ebuild
parente466209c898f09389f2308d193286ff62b46c1dc (diff)
gentoo auto-resync : 27:09:2023 - 11:30:42
Diffstat (limited to 'app-containers/catatonit/catatonit-9999.ebuild')
-rw-r--r--app-containers/catatonit/catatonit-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-containers/catatonit/catatonit-9999.ebuild b/app-containers/catatonit/catatonit-9999.ebuild
new file mode 100644
index 000000000000..1531acd41b04
--- /dev/null
+++ b/app-containers/catatonit/catatonit-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openSUSE/catatonit.git"
+else
+ SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ dosym -r /usr/bin/"${PN}" /usr/libexec/podman/"${PN}"
+}