summaryrefslogtreecommitdiff
path: root/app-containers/buildah
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-containers/buildah
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-containers/buildah')
-rw-r--r--app-containers/buildah/Manifest2
-rw-r--r--app-containers/buildah/buildah-1.24.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index bfc1e083721c..915e9d47ebb9 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,5 +1,7 @@
DIST buildah-1.21.1.tar.gz 11693142 BLAKE2B 513f75d8f2831130759f3bcb77fad311c28862b82df8866608bd909eea38468a6b576dfad2598725caa9c4e413108ea6ec3557c8a777017cc8a37b5cb16b70a1 SHA512 8fb30ed0948f898aef9a32c34d4b2a2e04a376257a73184ec01b67c770be1c3c87e46987ad001ececf2235cb5e17f9d0ff9e9f34be61ddd0935859c4e5b37d1f
DIST buildah-1.23.1.tar.gz 11872323 BLAKE2B 6e4cffd11177bca6c3e86cd3372fc7bf295b23559b7478a679ea2bea022c149b5ea058224f0a156df1b9511905795c44ed5e988ec68ca834dd80d0c198543d5f SHA512 2ceb6df5adb671483557bb03937df583857d99c116be5d44aae533c155f560d5d454bebf25908ac02bb85e4c2ba31533adb99f0946ecc4f4830977c14f324b6f
+DIST buildah-1.24.0.tar.gz 14143490 BLAKE2B c9883cc849d8837cdc4d31c02d49138f61b99f97fc40eb36494368eb47f1d74a24c6ddc4f631a043769ecb03906d11978afc7fae993a2f10346d9ac072d6e322 SHA512 337792cb896de3c10a66f7e2cf7c52d0dffd0ca8fede48a4d3a666d2a05e17bb3116db7c20a39805e9360b24a5df12d8ebd7a3818be12bb8e06e4b16cd62fc60
EBUILD buildah-1.21.1-r1.ebuild 1198 BLAKE2B fede3381b36b62849fc5dc494e4643ce97f349eb49b7470e9895e267838806fa21faf85fa0a17b1c2a4eccbd57bc0eb78184a6705a6245c5047551ad41e41b1d SHA512 c00fe7f79e286cb83b54b585bd062164b8c61b59cfa46e0b539b166acb6dd462be84935c0b50a3c6d974c6afa0161a1534495489e29dec6bc34555b65a4faa4c
EBUILD buildah-1.23.1-r1.ebuild 1196 BLAKE2B afd094d8fbefb9622704992892b8b0050fddae3d01e44275cd26f4d927f5c146cc577f8c374d7594083445ba581f7ef557660160725a977276e96ce5ed2f9006 SHA512 bdb5a798fc980be7e8d0c464784b48279af59b80a19a878f7134bb5344c8c807e5e16032f39a6d236ac653039cbf001fe40f64c9f4d2c26ea6ed7fed4805a588
+EBUILD buildah-1.24.0.ebuild 1198 BLAKE2B b9a9c19a840ad910d7b2c037e2f84195fae6e58ac50f282a768fd5eaef68dc34dd3056586f73462598b2e5f9429401d8ca8969e7c53b3d026608e6424b93dc19 SHA512 266e6888bddebcf95db82f85450fe6ea6d8436c4c2dbb631ff663d5d497c0a49a71ed23b3388440619487bdb145dc764c649f62e7d1dbd49c62e5044bbf6fb0e
MISC metadata.xml 328 BLAKE2B 55d2d2b5cc972b7e6b6fb77d14e79e304adcbc7056ff351f5ee3cac6cf5f83b4ef2a10c70754d1d30a5ecd88e652abc07cddd8005c3767e7f709c0c5cb61d068 SHA512 7520f5745909da195d4bfdd750e4c716c461a3789adfde56dd9be46b91dfb789653d642c0958b5a2950eea220cc00143bfcd5db402fcc2578c8fe5f8ff69275f
diff --git a/app-containers/buildah/buildah-1.24.0.ebuild b/app-containers/buildah/buildah-1.24.0.ebuild
new file mode 100644
index 000000000000..cc98ed8a4eb2
--- /dev/null
+++ b/app-containers/buildah/buildah-1.24.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+GIT_COMMIT=d9a41b85
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}