summaryrefslogtreecommitdiff
path: root/app-containers/buildah
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
commit564687d289b862b8b079569a45a2d39d7b8c3585 (patch)
tree9ec555a8f8005c24f9d8198ba4941cc6f002a413 /app-containers/buildah
parent30c47f3c341cb37e4808aaa3842b679d0ca420e8 (diff)
gentoo auto-resync : 22:01:2025 - 06:42:31
Diffstat (limited to 'app-containers/buildah')
-rw-r--r--app-containers/buildah/Manifest2
-rw-r--r--app-containers/buildah/buildah-1.38.1.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index e2bf378b5718..bdb079d7876e 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,6 +1,8 @@
DIST buildah-1.37.5.tar.gz 19323742 BLAKE2B 1c03cc201f10f4d3645ecd3dac9ae97b3fe585b63ca8980e22e8b13d6dab05842c47e694b45c13875f03dadf0a656177445b0f3835a8a6faca63b288ff136013 SHA512 ee33d85ea3aa9ec423b4e48e19db69359e3fc480a61abd511fa473257aa326e9a9c4dafc985afb83f7caa9a7a5ba6a89b2a1c028fe6ef7bd4ef382ec8591331d
DIST buildah-1.38.0.tar.gz 18547712 BLAKE2B a7c8df00ecc570d44173318adf68036389ce27bad5c10c7ba2bf7a728c29647186fcf0bfb9d0949e7947aff1e64cb2683b69ea0b4cb3d4181697813de8a5870f SHA512 c9f31693043e348c2bee6219f5a42738d93aa690a81f6bb283bd4d93ea6fe0cbde50754f7ee1a7e690853b7cfb934ce60e35ceb029180f41a95192773023c243
+DIST buildah-1.38.1.tar.gz 18550893 BLAKE2B 6342f70b75e1633bea2bc1902b1c4815799e3f8ed867a1c1df2e8fe0e016c16a4f94e1947ff073a0a079b55d047996cc7e89d78c1602b4642b525dcbb3ca59f3 SHA512 3c4738c4d30bece590da1de3ec8879e75d197bb18a1377264cf74f034574f46e27109842503aab0b98b1fd69f8762a13e80b1bd8522c5e3782ac0c451a07c3d8
EBUILD buildah-1.37.5.ebuild 3088 BLAKE2B 67e0f9d958907dc416e19f657a8a3f68022ac5214613716a23ace88d814c2433741f465756d718425817a3fabe61d0c39e2a8f46eb0535130acf83338b6f062e SHA512 1f341865dd92b2ebbcd1bca2a6ce9ee68778127514e81440edd97994971d05fc9af5b5f23717a36470afaeff485808cce9de0b8bba21359efa31baa9ca5c55c2
EBUILD buildah-1.38.0.ebuild 3097 BLAKE2B 1456523de66a5e6782c7114d519e69ca8bc9ff3853f0c915ec200d89e41166f7b7cc19dee0b894605589846aa5a5943736e1fa15686c4bc1e5ea74db05e9e336 SHA512 fb00ae023de7a3ae3a7f81cab73eda6f06701d36636fab7fae8263949a132c57466f27ba5d5cae0250503aceff8e40835e888d95182b90762947b0d7b52d7169
+EBUILD buildah-1.38.1.ebuild 3099 BLAKE2B 0f37c3edc2c0aa0b349ddbcb962a5abdb493999e0aa2b6e4489ef56024f415042639383d0c409097ed7ae6a1c9ab45536866c403e488228ba7ddf19a1c1e4908 SHA512 2e3f6177b301604a2605f475f29b3cd96d72937f8c3948df0dd5459d0fd32cd206a6f7178d908003dfcb348c497ad2c620cff5370e903291dff114edc2471813
EBUILD buildah-9999.ebuild 3099 BLAKE2B bb155ae447ceab425ed02f802e0b734d52e71bd7a6d2900de3f72d657159c086ff2bf7d2cd28f747c34e4db95d0bdcdb2522701a7b90655000b7dd160bf8f17d SHA512 8d2f3c3b591f4af7b3ea09d82e74b7ec12d653ef771b25fb24c25cb0114660922b35c85f910511a5464f914c4785f6f74600cd1af77a7cf572047b71d89ca61b
MISC metadata.xml 716 BLAKE2B 8d1868e48306b5ded8700bcfde93d2a0d1a4afedc5440781355f0645b5f71e5a80569be4b14ab459033c5ec7cf5f02eb49e3948154274ad09b088e09d8ac5069 SHA512 b8a7e951a5342ad1a32f650ab21d373c3afa86d482463d87dad5db0e6e715e3d4bde7642b75f68da7f5b4a7e935953ce2ac41affb66724e7882f75f97dfde023
diff --git a/app-containers/buildah/buildah-1.38.1.ebuild b/app-containers/buildah/buildah-1.38.1.ebuild
new file mode 100644
index 000000000000..df68d03e4ee4
--- /dev/null
+++ b/app-containers/buildah/buildah-1.38.1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module linux-info toolchain-funcs
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+
+SLOT="0"
+IUSE="apparmor btrfs +seccomp systemd test"
+RESTRICT="test"
+DOCS=(
+ "CHANGELOG.md"
+ "troubleshooting.md"
+ "docs/tutorials"
+)
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/buildah.git"
+else
+ SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp:= )
+ apparmor? ( sys-libs/libapparmor:= )
+ >=app-containers/containers-common-0.58.0-r1
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
+
+pkg_pretend() {
+ local CONFIG_CHECK=""
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ check_extra_config
+
+ linux_config_exists || ewarn "Cannot determine configuration of your kernel."
+}
+
+src_prepare() {
+ default
+
+ # ensure all necessary files are there
+ local file
+ for file in docs/Makefile hack/libsubid_tag.sh hack/apparmor_tag.sh \
+ hack/systemd_tag.sh btrfs_installed_tag.sh btrfs_tag.sh; do
+ [[ -f "${file}" ]] || die
+ done
+
+ sed -i -e "s|/usr/local|/usr|g" Makefile docs/Makefile || die
+ echo -e '#!/usr/bin/env bash\necho libsubid' > hack/libsubid_tag.sh || die
+
+ cat <<-EOF > hack/apparmor_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex apparmor 'echo apparmor' echo)
+ EOF
+
+ use seccomp || {
+ cat <<-'EOF' > "${T}/disable_seccomp.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -5 +5 @@
+ -SECURITYTAGS ?= seccomp $(APPARMORTAG)
+ +SECURITYTAGS ?= $(APPARMORTAG)
+ EOF
+ eapply "${T}/disable_seccomp.patch" || die
+ }
+
+ cat <<-EOF > hack/systemd_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex systemd 'echo systemd' echo)
+ EOF
+
+ echo -e "#!/usr/bin/env bash\n echo" > btrfs_installed_tag.sh || die
+ cat <<-EOF > btrfs_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
+ EOF
+
+ use test || {
+ cat <<-'EOF' > "${T}/disable_tests.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -56 +56 @@
+ -all: bin/buildah bin/imgtype bin/copy bin/inet bin/tutorial docs
+ +all: bin/buildah docs
+ @@ -122 +122 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
+ EOF
+ eapply "${T}/disable_tests.patch" || die
+ }
+
+}
+
+src_compile() {
+ # For non-live versions, prevent git operations which causes sandbox violations
+ # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
+ [[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+
+ tc-export AS LD STRIP
+ export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
+ default
+}
+
+src_test() {
+ emake test-unit
+}
+
+src_install() {
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
+ einstalldocs
+}