summaryrefslogtreecommitdiff
path: root/app-containers/apptainer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-containers/apptainer
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/Manifest3
-rw-r--r--app-containers/apptainer/apptainer-1.0.0.ebuild63
-rw-r--r--app-containers/apptainer/metadata.xml15
3 files changed, 81 insertions, 0 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
new file mode 100644
index 000000000000..63c6755d6c1d
--- /dev/null
+++ b/app-containers/apptainer/Manifest
@@ -0,0 +1,3 @@
+DIST apptainer-1.0.0.tar.gz 11978144 BLAKE2B ca2444fedbd669e6da1a9bbc7c1561dfa8ddebcf82e14ce3233e7e4bbb743eb4b4289aeb1977afe4871ee3abc453ed61821fc25f5b28a0dbfe708253ec031fd9 SHA512 c772b9286d54b21112dba98b7361fac7e1661616643851dc12f58b2565a51d145806f8e5b5dc635b357526e5d270bea096498dcd6c40635530ec3beced6f582f
+EBUILD apptainer-1.0.0.ebuild 1455 BLAKE2B 7597124c81907ce80b3bd59334355054de6c79f560c7a1e25d307cbebd4d7aaac38e98585d9071ab32717682683a401213f4f8c87b222a7a7e8cb4a59885af31 SHA512 3391d40fa87d3e162707e9e5b475d83a2b300ad659a4ea5e96d8ae7c64e610615eb8078c5e57b854809472b336b6175077fe941dc0ec8f3cecd25b97ffb4be51
+MISC metadata.xml 454 BLAKE2B 7891b6acae30424b8b6877166b856c1113a13e40ebec9051935df10a0650bf941f52d75bdb6a4258795e07b080082979469b8b8242d2ddd56c52f9c5b6759f0e SHA512 ef53c2dee45734f36403ab71549494f3c24707bc183353e4bd9c548a97b3ab5d7877f4fc9d311d9e86ab249cbdb379f0a1a211ee36afda99fd552f0a5cac30bb
diff --git a/app-containers/apptainer/apptainer-1.0.0.ebuild b/app-containers/apptainer/apptainer-1.0.0.ebuild
new file mode 100644
index 000000000000..9f711a070ada
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.17.6
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp"
+RDEPEND="${DEPEND}
+ !sys-cluster/singularity"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/app-containers/apptainer/metadata.xml b/app-containers/apptainer/metadata.xml
new file mode 100644
index 000000000000..069f7e2cb731
--- /dev/null
+++ b/app-containers/apptainer/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <use>
+ <flag name="network">Install network plug-ins</flag>
+ <flag name="suid">Install SUID helper binary</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">apptainer/apptainer</remote-id>
+ </upstream>
+</pkgmetadata>