summaryrefslogtreecommitdiff
path: root/app-cdr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-09 12:24:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-09 12:24:59 +0100
commitc218398bbbe70a616790cf146c28c1066b9284bf (patch)
treea598e8c85afbc52bb7eca18ae415ef4971e65c8f /app-cdr
parenta5442e2318cb4df55867389654e322dbac82067e (diff)
gentoo auto-resync : 09:07:2024 - 12:24:58
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/Manifest.gzbin7511 -> 7511 bytes
-rw-r--r--app-cdr/cdemu-daemon/Manifest2
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild51
3 files changed, 53 insertions, 0 deletions
diff --git a/app-cdr/Manifest.gz b/app-cdr/Manifest.gz
index b551222802ef..a6c6d2623f91 100644
--- a/app-cdr/Manifest.gz
+++ b/app-cdr/Manifest.gz
Binary files differ
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 0fe60541923a..119ece885b07 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1,3 +1,5 @@
DIST cdemu-daemon-3.2.6.tar.xz 85976 BLAKE2B 33d03324fbc222674967f1d6b93c2bf1793528948cfce1089dbdfe799d3b40eaabae2e3f62b4696eba020f04c192e9d458a91e8bdd85465e00ec5a84194982e0 SHA512 cead8e4f7e0eec6e1284924cfe88cdfb78ec9f0769ffa423cd1801261540b3806a9704b6abbddc175e9e7d1aeef2acb9889b36ed13d89fd4b9dcda91fe1a08ca
+DIST cdemu-daemon-3.2.7.tar.xz 86140 BLAKE2B 09e968636bb95b0cb205a94769e2ba278f66199bb23c6db0f2860fa621f33bb37b6e55028dabec98a6fc7cf6aded42a1bb8d153381110bf38b678a74a2b5c8db SHA512 c09ae0e32526c85b6bb001a5cf8c11ed3662390e16fad8c07e5cded7febe4c586e8c677c85340fb20e321dfc3621e15b4a4220606147adc14ab969d6924778aa
EBUILD cdemu-daemon-3.2.6.ebuild 1248 BLAKE2B 31ef50a145d0588b7ce53b5575abbbfd08ff598bc36f88194e0d35d74256ec2ca0e3e938835a07fa8b40bf8f64492cac8626300e28a97a70563918dcdf2bf5f5 SHA512 b336c2c7388383f943e3bf4cd5e23e9700b65ed6f2379a57da898beab60d411e8868604ccbb253d91e5a6249eedc4f2c747a5a54cb24dd3d42b647bc51c368e6
+EBUILD cdemu-daemon-3.2.7.ebuild 1257 BLAKE2B 260d5199fe6105a60c604725d11638351f0ed6d92e01e783fea33abda9f7d58df007bbed93404df91b11097928fc637a74a1c1bc5d4cba22f5f91a28ca24d677 SHA512 86916c9547ac5891a07ed772487c42fbabea9d61ea53b358099970b69be4e947d9d34e27e746cbccdc1ee33cd70d25b0ade378ce6719b7617c1c5a2b6b8723fe
MISC metadata.xml 333 BLAKE2B 99feb77e860cccd95f60688c7c2104267b6abb6188a8f24e50728b39487892ef29c58e5ddfb7a56578d27c34e9d4bb16371298449d2a3de5e6a79a6a5712e37c SHA512 2a387604d78412e81477271c793d46b197609d4d9037aa55d0146cfbbc9eae01633a7a9ac6908f923174ecfedf7336792147dc6e7c5b13db057855282e45e129
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild
new file mode 100644
index 000000000000..225e87f3eea2
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:=
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/modules-load.d
+ newins - vhba.conf <<<"vhba"
+ systemd_douserunit service-example/cdemu-daemon.service
+ insinto /usr/share/dbus-1/services
+ doins service-example/net.sf.cdemu.CDEmuDaemon.service
+}
+
+pkg_postinst() {
+ elog "As of 3.2.5, cdemu-daemon no longer supports autoloading"
+ elog "on non-systemd systems. OpenRC users have to start it manually."
+ elog
+ elog "We install /etc/modules-load.d/vhba.conf to load the module"
+ elog "automatically, and D-BUS autolaunch will start cdemu-daemon user"
+ elog "service."
+}