summaryrefslogtreecommitdiff
path: root/app-cdr/isomaster/isomaster-1.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-cdr/isomaster/isomaster-1.3.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-cdr/isomaster/isomaster-1.3.5.ebuild')
-rw-r--r--app-cdr/isomaster/isomaster-1.3.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-cdr/isomaster/isomaster-1.3.5.ebuild b/app-cdr/isomaster/isomaster-1.3.5.ebuild
new file mode 100644
index 000000000000..c3da00580be0
--- /dev/null
+++ b/app-cdr/isomaster/isomaster-1.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Graphical CD image editor for reading, modifying and writing ISO images"
+HOMEPAGE="http://littlesvr.ca/isomaster"
+SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.diff
+}
+
+src_configure() { :; }
+
+src_compile() {
+ tc-export CC
+ emake PREFIX="/usr" || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die "emake install failed"
+ dodoc {CHANGELOG,CREDITS,README,TODO}.TXT
+}