summaryrefslogtreecommitdiff
path: root/app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 07:57:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 07:57:57 +0100
commit27f7ac2204449d9fc2137f442522b4fb10327d90 (patch)
treee0fa5de044037be9ff62dcb6bcc8dbeca087767d /app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild
parent84a400be40cf32d9e536ae34ebf14ad06ad6b8d6 (diff)
gentoo auto-resync : 19:10:2022 - 07:57:56
Diffstat (limited to 'app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild')
-rw-r--r--app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild b/app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild
new file mode 100644
index 000000000000..b14a4594871a
--- /dev/null
+++ b/app-cdr/extract-xiso/extract-xiso-2.7.1_p202204252159.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PV=${PV/_beta/b}
+
+DESCRIPTION="Tool for extracting and creating optimised Xbox ISO images"
+HOMEPAGE="https://sourceforge.net/projects/extract-xiso"
+if [[ ${PV} == *_p* ]] ; then
+ SRC_URI="https://github.com/XboxDev/extract-xiso/archive/refs/tags/build-$(ver_cut 5).tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-build-$(ver_cut 5)
+else
+ SRC_URI="mirror://sourceforge/extract-xiso/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
+fi
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"