summaryrefslogtreecommitdiff
path: root/app-cdr/cdrdao
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-cdr/cdrdao
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-cdr/cdrdao')
-rw-r--r--app-cdr/cdrdao/Manifest3
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.4-r1.ebuild51
-rw-r--r--app-cdr/cdrdao/metadata.xml12
3 files changed, 62 insertions, 4 deletions
diff --git a/app-cdr/cdrdao/Manifest b/app-cdr/cdrdao/Manifest
index ccab6ca0d11c..ccdf965e97be 100644
--- a/app-cdr/cdrdao/Manifest
+++ b/app-cdr/cdrdao/Manifest
@@ -1,5 +1,6 @@
AUX cdrdao-1.2.4-ax_pthread.patch 16846 BLAKE2B a76c7c68c53a57731e652325d98f9f2ce434c9c9385e8583fb948fe2e1c120ad564a95bc247993493afbef1163206c30fc8a141d72ee723b3bcabb20a5f9f36a SHA512 83789963569dbaa599294bd79447e3351309675817eef683e2f90974d68fda00c705eca43c015128d6c6e9ec98f14bf7f205f8e3ab46f33c1bf0afaf0f055694
AUX cdrdao-1.2.4-wformat-security.patch 4864 BLAKE2B fa300eefe5d714de0245a9e745d13f051dcbc14590efb33a367dd113474984618e62e347fc3cdc26a057169ff95bdde25b36d9b7bcb25aa9cdd5fd9b07a42ec1 SHA512 a40fd8c91fa207ad52f3cde9318fc4422f14aeea15bab4d2cd1e04d3f09a2fc2b666397cdbddc89245c97a6a98ac155c0ecf71c1e2993a366a21016bd337a33e
DIST cdrdao-1.2.4.tar.bz2 1442181 BLAKE2B e1163b25c165a7acd7ec8c53069794724d93f09a486150255a58985e3fd0a222ba7ac5c124cb7a6991cf440ac701651be38754615fd3d0d295affa93595dc388 SHA512 41f20275ca44ec9003d0e3ed280cc98012353005cda6f544ebfa44f3f79f991845c0ef17af74db9456f1bacc342a7fd48c9e942d757927a4a9ff91808f7bbb09
+EBUILD cdrdao-1.2.4-r1.ebuild 1031 BLAKE2B 6a0ec89b5a0c5b01e9cc24dcf5170c9c5b3197aab87066c606255868f55cd52b6e011ace349d885a9c04661d56db49776c91b4acdb274935748082855e36d535 SHA512 eda054c6904d5608aaf4cb33cd4677185eb1d0ce5ab154cea97545109d7ebf1d14e0fba5cc7e97c197e8e17717f72bea8c473bf76665494e3fe3fb77a327eb77
EBUILD cdrdao-1.2.4.ebuild 1284 BLAKE2B 7485eaab37ac6a7135b9eee4fc5662ba3627bce46a059296c5f19320f35c0b3c48ccbf1ad583eb1ed5dc860cf24f6f15903317369384d628fb1fc848d9073d78 SHA512 42a46ff652308f2aa7595dde209a5757d51825090132527d2bd28cba019b0d860699e970c0e4f6d28afc95c48a9a235b0b47bbca652142391b28fa059e5f1bd3
-MISC metadata.xml 396 BLAKE2B 3ff854150552e92c6c593a97364fffc98f7618115adf29fc6f1bbbece071a72400b0119a1fe088d9c73cb2f4c561a4a2174e4ff970194e37a8688f305ee352d8 SHA512 4e3d11ed9565d6f406fc78f190e0cc08f81f8f5cb4090f568bc11324100794a0856cdad99a521dd729cdfe7c1c53cac35f9e886de1eb5d2567cfbc5681f66a8c
+MISC metadata.xml 625 BLAKE2B ff700b39fec5af69fa8cb3b67b739f27c377ff403d6d6d7ff6683bc692a8ff39460cb368e8d7953d6ccfba8742eebb2399da02023677fc4569faabf32ec72325 SHA512 caf28974318f108e9cb51245a2f42431f32663a7b87d40437faeb4e2350572901ff9d78eb946a11d6be74cdd7f3ff7f42d98033cb44965d0a6b22d82eeac286e
diff --git a/app-cdr/cdrdao/cdrdao-1.2.4-r1.ebuild b/app-cdr/cdrdao/cdrdao-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..4bdda62111a1
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
+HOMEPAGE="http://cdrdao.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="encode mad vorbis"
+
+DEPEND="app-cdr/cdrtools
+ encode? ( >=media-sound/lame-3.99 )
+ mad? (
+ media-libs/libao
+ media-libs/libmad
+ )
+ vorbis? (
+ media-libs/libao
+ media-libs/libvorbis
+ )"
+RDEPEND="${DEPEND}
+ !app-cdr/cue2toc"
+BDEPEND="gnome-base/gconf
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ax_pthread.patch"
+ "${FILESDIR}/${P}-wformat-security.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ local myeconfargs=(
+ --without-gcdmaster
+ $(use_with vorbis ogg-support)
+ $(use_with mad mp3-support)
+ $(use_with encode lame)
+ )
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-cdr/cdrdao/metadata.xml b/app-cdr/cdrdao/metadata.xml
index 7dc22fa1c02f..c4d81bdcb729 100644
--- a/app-cdr/cdrdao/metadata.xml
+++ b/app-cdr/cdrdao/metadata.xml
@@ -1,10 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>martin.dummer@gmx.net</email>
+ <name>Martin Dummer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>
- CD command line recording, ripping and copying tool. Especially ISOs- and
- bin/cue-files are handled very well.
+ CD command line recording, ripping and copying tool. Especially ISOs and bin/cue-files are handled very well.
</longdescription>
<upstream>
<remote-id type="sourceforge">cdrdao</remote-id>