summaryrefslogtreecommitdiff
path: root/app-cdr/cdemu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-cdr/cdemu
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-cdr/cdemu')
-rw-r--r--app-cdr/cdemu/Manifest2
-rw-r--r--app-cdr/cdemu/cdemu-3.2.5.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/app-cdr/cdemu/Manifest b/app-cdr/cdemu/Manifest
index b3d353ee45dc..2c9fa5304214 100644
--- a/app-cdr/cdemu/Manifest
+++ b/app-cdr/cdemu/Manifest
@@ -1,3 +1,5 @@
DIST cdemu-client-3.2.4.tar.bz2 44284 BLAKE2B c57fe09bef7112933a93fac9944eaff957e01692ec1ddec7fd443aa780f8b3d85d0bd640611337d896843de3ab00d09e093c293776a52afa85f781bdde7f4250 SHA512 2e10cb345e261ddaa6da68ee626770ed65749b1ea64c2bbbf0f3a2e96184c2906834886754e87e3161c3056473e5ee0dc20672ce7cb48232e6bef1c93cb80550
+DIST cdemu-client-3.2.5.tar.xz 41596 BLAKE2B 5b3e5a16f9daa0ab2c670a8cba54af380894e668c87a64a5e2126777d6725420d9bb7f41290ca69eba12e20db97b00cc74aea3df9694ef331e7a571b913820b1 SHA512 d143705607507503cd7828f02e7a0fbe5d33f15e28ce61f453567d8635ed863c5b508ed2b1964f034d846ecdea752bd3dfb565350174db3e06cf7d29c2f828bf
EBUILD cdemu-3.2.4.ebuild 1148 BLAKE2B 2cd75916330a18dbee969689c64280a8513677ef30939a53dc9991ab03f9fe9ecfdebfd9109fae72073b2dfebd07b0e021a9bffdcfc0682f5f33f5ea5edeb3a5 SHA512 519f6cbffec8f58cd8d9bdcc796fc982a0f5440a177929487f1935ac05bb8ac95f0387fac5392543fde04b2f3e780bfb725bcac9743bb5b240eea931fed91038
+EBUILD cdemu-3.2.5.ebuild 1282 BLAKE2B 4eb0f5ca3cb7aa2e86c4260e1c77d2cca7f89cfaf8b212c420eaec0519085a9970ebe7c7e5833d870c27ec0dbaccdef724a5ff6f73037c026af7dce6283fe2aa SHA512 49a4e663981dfcc4c0b051297fdc3f746ab3fdc4ae751ed80e5566bd987c34ec26545017a2ac22dfbba3f7bf3b821c7a994937dd9953806b2643dc3edb553712
MISC metadata.xml 529 BLAKE2B 88d72a301708901597eb11c475ae67d8477381c77d430b49042cb4a8658aa44b88273858f87cbbaa1fc16ae222b604fa9ff81f6f791d39c39d5c76b58b9d0d81 SHA512 27850929d16910038f7b406c0ec4c22648c91a6f8a8f9cd56c0a3ea8e4e772de9b77598514c5a621eb71386635a327829251a90128ba33073ac34485a3b60a92
diff --git a/app-cdr/cdemu/cdemu-3.2.5.ebuild b/app-cdr/cdemu/cdemu-3.2.5.ebuild
new file mode 100644
index 000000000000..6187021b80e4
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-3.2.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit bash-completion-r1 cmake python-single-r1 xdg-utils
+
+MY_P=cdemu-client-${PV}
+DESCRIPTION="Command-line tool for controlling cdemu-daemon"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-client/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cdemu-daemon"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
+BDEPEND="${PYTHON_DEPS}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake_src_prepare
+
+ python_fix_shebang src/cdemu
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPOST_INSTALL_HOOKS=OFF
+ # requires bash-completion as BDEPEND, better install it manually
+ -DENABLE_BASH_COMPLETION=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newbashcomp data/cdemu-bash-completion.sh cdemu
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}