summaryrefslogtreecommitdiff
path: root/app-cdr/cdemu-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /app-cdr/cdemu-daemon
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest2
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 23058e65cc95..007627279a79 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1,3 +1,5 @@
DIST cdemu-daemon-3.2.2.tar.bz2 82366 BLAKE2B d21436a5dbf1c6d953aa7ceb58e5d4580931391ea407c45de8f7c7154c181aef76535833bf02999d77d3a9e0c624db1124a9d333d028e206844a1256b3c5dde0 SHA512 4010bad27d5f595d20e1666700d32c2fb3f943f2e50645317bcc8fbbbba58cd61b3f6d3276e91fff55f449e44291abc776a56ded7c4f0bb7901ac247da72d7fe
+DIST cdemu-daemon-3.2.3.tar.bz2 83130 BLAKE2B 2be64beb662ebeb51d75a34bccece5f5eede8abe447d4d0be60bf1bbe4e1f9ac6eeaa67783f763f4966571cf4e13fb9b61610ead40d8a13842400f48bb3b1618 SHA512 a1c7fdea9e32e71591a29de98f28dd4d2d0ffb972861916ab287ff33f5f070da8fcc113b602e4b02fd08a72f7361ae85440ef5eb156e312a849cd716207026a7
EBUILD cdemu-daemon-3.2.2.ebuild 1140 BLAKE2B 37bf7e266dcbf187004b9e6184176791873d8a6ef29d11e2a0348d606affd72ae5fe8a0ced71e44c460ec218cdb41dd4073539000920fc290adfa7a7a10c2383 SHA512 2e05466f5bdec9615e5bc03343706b2abd1c310532364fb09454170aa2389f70bb490a1538e2097dadb73131907f2820e4b9ca8f774f12c1a94d1e922e322adf
+EBUILD cdemu-daemon-3.2.3.ebuild 1176 BLAKE2B db60513ec861afeae0844c55fd37e1ec2e7f44b441d737cb3336ab9344a5d794b7dd9c2f05d373f9b2b77a0fab43630e3bffb4d1e883ec693d16e4a6f4fbe03e SHA512 29411e441324b114183bcd3af7068fabd691cf0ca5e0ce8f7b7dfdc1ac789aa5e81bd2569a89402ed3237fd872c3e21ee3d11088b527b46367880d90afca040e
MISC metadata.xml 332 BLAKE2B 0be8fdf09b872003fbd913a72966a059ad2d0870b281e6b86b19cf52f8c32b113d392dd71c85281f2f1abcb0933b592fb2112c18fe70359af7c7aacc9ff3a011 SHA512 d8bf249636b4dfda07c67e935bdd4b7392543fe31e2bf8c153954f4d680db45b0090f9bd89399f0241554a311b604185737c2bb7e64df43ea25adda9ee7468a0
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild
new file mode 100644
index 000000000000..abedc85833f8
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}/etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}/etc/conf.d/cdemud"
+ fi
+}