summaryrefslogtreecommitdiff
path: root/app-cdr/cdemu-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-cdr/cdemu-daemon
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest2
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.6.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 650e9f550236..2ff4a25792f4 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1,5 +1,7 @@
DIST cdemu-daemon-3.2.4.tar.bz2 83580 BLAKE2B 56cfde3b9b9a98ba0da629deac717a740b7c92c67195ac282af5337f0e782b555f53221741a59abf3e78faacd066e34a722d08e27cef6fd1082cb75b46eb3ace SHA512 b5dd19a9325773e22c1910ae02f351803fb4f02197eaf5d41a984b4898a5fb0f027c70791d4c25553a9b589273fa3578d3cb12aa7a056f8639b341bd2ab44291
DIST cdemu-daemon-3.2.5.tar.xz 85948 BLAKE2B f9b977ce964b15835afef54131cc158bc45389af30739706d93984bc24787b95034d9da7d56e88e018be9db66c185c16b7cf7481e0fdd0e97fed9e55b61419fd SHA512 6b084dc1809c9ccf8f9c24c671f13259d2e1ca6d2e6f7f85d44a47b4e973a68d7c92e470071421cdf6f2142eb26bdfd277a2f9c85b960d0b315b51a2d65953c7
+DIST cdemu-daemon-3.2.6.tar.xz 85976 BLAKE2B 33d03324fbc222674967f1d6b93c2bf1793528948cfce1089dbdfe799d3b40eaabae2e3f62b4696eba020f04c192e9d458a91e8bdd85465e00ec5a84194982e0 SHA512 cead8e4f7e0eec6e1284924cfe88cdfb78ec9f0769ffa423cd1801261540b3806a9704b6abbddc175e9e7d1aeef2acb9889b36ed13d89fd4b9dcda91fe1a08ca
EBUILD cdemu-daemon-3.2.4.ebuild 1137 BLAKE2B d7f1e6223350898280bd4fc40ea09cb3906b0cc8c5c4f11b999234a13008e3346ea9f40c74bea10dd189b6e71d9c6a8370df286cd406c6671ad2849e3fff7cd5 SHA512 8db90ffaae996a013b7977eb6ff7c35502cc4a76776028c657b9d64968a59e50348624d971b9e5683273a4c12892ae01ea1b2659d67e41bdc83baf44336c58f9
EBUILD cdemu-daemon-3.2.5.ebuild 1248 BLAKE2B 5029e96ff3d723425f528dc730ee6667ce187a5a57266c1896468bc75312b8f6f634ae7e2e4140251e32757ba006290364f790772fef3a1ea3dc92cc185df3d5 SHA512 10fcef4225daa7fbf993a00673139831ca9e0b87589da3b476caf6ed0b4fd83513427d370e0625e36915fedd0266b315f80ac4def68ad4ba6852fe49820ece72
+EBUILD cdemu-daemon-3.2.6.ebuild 1250 BLAKE2B 0451eb13c3047608826e556639c99931b9645b97a5a9b16a4bea5a02dd926939639f97c9de9c934e4bb9d92757c4e2e81ea6c2ec7dbc0b22421755c9bbd18ed3 SHA512 437dfa697e7fb1c5cb82ddc9e58ae86d076d77ae6adad57853cc89b474511b75f00ecbae4e2aa77d14b946a9d090676d3ae1f8d98bd3c2754dac3a63f25eb6b4
MISC metadata.xml 333 BLAKE2B 99feb77e860cccd95f60688c7c2104267b6abb6188a8f24e50728b39487892ef29c58e5ddfb7a56578d27c34e9d4bb16371298449d2a3de5e6a79a6a5712e37c SHA512 2a387604d78412e81477271c793d46b197609d4d9037aa55d0146cfbbc9eae01633a7a9ac6908f923174ecfedf7336792147dc6e7c5b13db057855282e45e129
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.6.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.6.ebuild
new file mode 100644
index 000000000000..ddfa7e43cf65
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/modules-load.d
+ newins - vhba.conf <<<"vhba"
+ systemd_douserunit service-example/cdemu-daemon.service
+ insinto /usr/share/dbus-1/services
+ doins service-example/net.sf.cdemu.CDEmuDaemon.service
+}
+
+pkg_postinst() {
+ elog "As of 3.2.5, cdemu-daemon no longer supports autoloading"
+ elog "on non-systemd systems. OpenRC users have to start it manually."
+ elog
+ elog "We install /etc/modules-load.d/vhba.conf to load the module"
+ elog "automatically, and D-BUS autolaunch will start cdemu-daemon user"
+ elog "service."
+}