summaryrefslogtreecommitdiff
path: root/app-cdr/cdemu-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-cdr/cdemu-daemon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest5
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild41
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild42
-rw-r--r--app-cdr/cdemu-daemon/metadata.xml15
4 files changed, 103 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
new file mode 100644
index 000000000000..39ab7e16b4ae
--- /dev/null
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -0,0 +1,5 @@
+DIST cdemu-daemon-3.1.0.tar.bz2 79943 BLAKE2B 23407c3a14b426fa9f53c2d62564e34a8f878598c24cdd9419c811786d858135a0af3a1cde8b7afc4178f7772336ed533077c089c976e98de30c932deca1c426 SHA512 f0f3de31b2bf6a97852bb1bc45d301e6cbf401ca7499f42e99811ca62431e86b344c83ddb4420571f2038e43432711e04817b9ed3859893eec7d36fbad8dfdb5
+DIST cdemu-daemon-3.2.1.tar.bz2 82426 BLAKE2B 282b1a62ca3a770e709ff31ee7b72ed9f5e102c5f318a765a99421c93881e9ecacfdc5867af494e69dddda40603c8eb6cc8904a7c82fec004a6d5644a28a9f87 SHA512 399dbb818de8a550bd31784a5a7f0adb9d2e35d922ba71f341df81d20fd7e5ebaba5f31db1554caca17919325773f9ec6bb3d5ae99afa5d6eaf5b22142e010ee
+EBUILD cdemu-daemon-3.1.0.ebuild 1110 BLAKE2B 001cea1a051505de440cf792f5c561617312d8b946675623d47a204bc7e4b94ad4fa5e4ed8e2bdcb8d47483a0f33d8c2ffdbb935ffe3f401e90358f45de8d97e SHA512 ee7fdd166e61e9a9e6339629d46ed9c6aa91984e0e2b357958aa40d79c3401cde0d9fdf24942708074a7389b66205b6b38ad156674581cd68f16e89284093d14
+EBUILD cdemu-daemon-3.2.1.ebuild 1151 BLAKE2B 7fcb6614be31951e77ce310a9b7709163c0ac33c858dfd2eea28dd0fbf9cc2597e65bedefa23ff4e50a8489f2b238e290bb691df69b85c049feb23c5f3e1b988 SHA512 4ce6f56fee85b7ff547080064c04da44345f6dda25fffefd1afa720e48d864596f489f53630fbeca10383366b93367610de66ec8e47eabe7bd63a6b3c1c3eca0
+MISC metadata.xml 455 BLAKE2B 23500677c263c1b8fc4839698bd6f1c08e9821fe4472a0b1725ad4777cfff385531ab6ec966f32a2335571c315b6f886f973451076745aa9fe4297c3cc436a30 SHA512 51c8d87f3c49c81798e4d2e038f911a2e05bfde742f229939f759c6768c6459cf4aa6829981791c57ef766fd447923194d7c14d4ad16951ae505d3b5a73c3479
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild
new file mode 100644
index 000000000000..e7bdef53c7de
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild
new file mode 100644
index 000000000000..d3509f5f2628
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}
diff --git a/app-cdr/cdemu-daemon/metadata.xml b/app-cdr/cdemu-daemon/metadata.xml
new file mode 100644
index 000000000000..3c7b1adb6301
--- /dev/null
+++ b/app-cdr/cdemu-daemon/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cdemu</remote-id>
+ </upstream>
+</pkgmetadata>