summaryrefslogtreecommitdiff
path: root/app-cdr/cdemu-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-cdr/cdemu-daemon
reinit the tree, so we can have metadata
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest5
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild41
-rw-r--r--app-cdr/cdemu-daemon/metadata.xml15
3 files changed, 61 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
new file mode 100644
index 000000000000..53a1c39b53a7
--- /dev/null
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -0,0 +1,5 @@
+DIST cdemu-daemon-3.1.0.tar.bz2 79943 SHA256 498f0f2fe2225de76acfe0b3dbf9606e4e2eb57ac9d29da9d48064b62587bc4f SHA512 f0f3de31b2bf6a97852bb1bc45d301e6cbf401ca7499f42e99811ca62431e86b344c83ddb4420571f2038e43432711e04817b9ed3859893eec7d36fbad8dfdb5 WHIRLPOOL 52768032e498607879ddecf96a6d5c909293488ec93c55aae7e9c0537e5b9d12567f6b3bc70c74fb65756a379bb7248954009c1f79ebd1e9090b36fe19b0ca80
+EBUILD cdemu-daemon-3.1.0.ebuild 1110 SHA256 e3bd51a6deba7064c875291a880b32666495be79b47b00c52bb832634ac03bd6 SHA512 ee7fdd166e61e9a9e6339629d46ed9c6aa91984e0e2b357958aa40d79c3401cde0d9fdf24942708074a7389b66205b6b38ad156674581cd68f16e89284093d14 WHIRLPOOL b8d5f119d0ea3fd3729918c371259bc69d5b173cca6c3cb8af627269265787a854704ff4c2ce61dd774e69a828ea2bf5b22a37bfc6a9088e7fbee5b7397cd6d9
+MISC ChangeLog 3100 SHA256 7c64ad29e276b76f65b9f0e3a43e19ee524124fa44eff36bff10b31c17f612e2 SHA512 3cc695e929580826d92cf9ffdcd11e9a23e66262eb04b656b80d6c94f7a011cabbb2a08bf50c9cb2dbb88960db370e5efc79a8b920b488e02bf3213b899c6e54 WHIRLPOOL 8688fe61f2f74b13a199f3ca2fd86d42d21aef6df5cc27dbbd0fab4bf714dcacde846f57ab1e59ca04aa7453b895bd5f92277c076aa2db0521c7926faeb1353b
+MISC ChangeLog-2015 6852 SHA256 51c439202e2a7a8eeda89c3c3eda0183f0084bb25bbe8d5fb8108b7f1c16d021 SHA512 ac930a7d8d7db6b9484a7e67bfca6ebd1538b947fcdc8bdbdb782abb56ef98441e8adbb5f458837fb1efcd470f3ee551c9c1bcb2effe9c544de402ef938d19dc WHIRLPOOL 43cfc11224dcaab915ed1b6dc911815858bfd937779b7455c9942c79715842abe4c92da118e3dace79a7ba5f5123c0d7da427866b1bce37418baa9a2ca7c6cec
+MISC metadata.xml 455 SHA256 07a8d13abb61a51f6dab1c9f0a8892b806da028e300d36cbfb639e2a4e92ed9d SHA512 51c8d87f3c49c81798e4d2e038f911a2e05bfde742f229939f759c6768c6459cf4aa6829981791c57ef766fd447923194d7c14d4ad16951ae505d3b5a73c3479 WHIRLPOOL 789f78c7079cea5fe08400d0d66b83a0eb65fa88569250b82117797c15383c141d655e0ab2191cd7b8ea20052b697254993f9c4870f28a50b4ae4faa973310c9
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild
new file mode 100644
index 000000000000..e7bdef53c7de
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}
diff --git a/app-cdr/cdemu-daemon/metadata.xml b/app-cdr/cdemu-daemon/metadata.xml
new file mode 100644
index 000000000000..3c7b1adb6301
--- /dev/null
+++ b/app-cdr/cdemu-daemon/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cdemu</remote-id>
+ </upstream>
+</pkgmetadata>