summaryrefslogtreecommitdiff
path: root/app-cdr/cdemu-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-cdr/cdemu-daemon
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest2
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 66687da09efe..3889066782c1 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1,3 +1,5 @@
DIST cdemu-daemon-3.2.4.tar.bz2 83580 BLAKE2B 56cfde3b9b9a98ba0da629deac717a740b7c92c67195ac282af5337f0e782b555f53221741a59abf3e78faacd066e34a722d08e27cef6fd1082cb75b46eb3ace SHA512 b5dd19a9325773e22c1910ae02f351803fb4f02197eaf5d41a984b4898a5fb0f027c70791d4c25553a9b589273fa3578d3cb12aa7a056f8639b341bd2ab44291
+DIST cdemu-daemon-3.2.5.tar.xz 85948 BLAKE2B f9b977ce964b15835afef54131cc158bc45389af30739706d93984bc24787b95034d9da7d56e88e018be9db66c185c16b7cf7481e0fdd0e97fed9e55b61419fd SHA512 6b084dc1809c9ccf8f9c24c671f13259d2e1ca6d2e6f7f85d44a47b4e973a68d7c92e470071421cdf6f2142eb26bdfd277a2f9c85b960d0b315b51a2d65953c7
EBUILD cdemu-daemon-3.2.4.ebuild 1137 BLAKE2B d7f1e6223350898280bd4fc40ea09cb3906b0cc8c5c4f11b999234a13008e3346ea9f40c74bea10dd189b6e71d9c6a8370df286cd406c6671ad2849e3fff7cd5 SHA512 8db90ffaae996a013b7977eb6ff7c35502cc4a76776028c657b9d64968a59e50348624d971b9e5683273a4c12892ae01ea1b2659d67e41bdc83baf44336c58f9
+EBUILD cdemu-daemon-3.2.5.ebuild 1250 BLAKE2B 0451eb13c3047608826e556639c99931b9645b97a5a9b16a4bea5a02dd926939639f97c9de9c934e4bb9d92757c4e2e81ea6c2ec7dbc0b22421755c9bbd18ed3 SHA512 437dfa697e7fb1c5cb82ddc9e58ae86d076d77ae6adad57853cc89b474511b75f00ecbae4e2aa77d14b946a9d090676d3ae1f8d98bd3c2754dac3a63f25eb6b4
MISC metadata.xml 332 BLAKE2B 0be8fdf09b872003fbd913a72966a059ad2d0870b281e6b86b19cf52f8c32b113d392dd71c85281f2f1abcb0933b592fb2112c18fe70359af7c7aacc9ff3a011 SHA512 d8bf249636b4dfda07c67e935bdd4b7392543fe31e2bf8c153954f4d680db45b0090f9bd89399f0241554a311b604185737c2bb7e64df43ea25adda9ee7468a0
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild
new file mode 100644
index 000000000000..ddfa7e43cf65
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/modules-load.d
+ newins - vhba.conf <<<"vhba"
+ systemd_douserunit service-example/cdemu-daemon.service
+ insinto /usr/share/dbus-1/services
+ doins service-example/net.sf.cdemu.CDEmuDaemon.service
+}
+
+pkg_postinst() {
+ elog "As of 3.2.5, cdemu-daemon no longer supports autoloading"
+ elog "on non-systemd systems. OpenRC users have to start it manually."
+ elog
+ elog "We install /etc/modules-load.d/vhba.conf to load the module"
+ elog "automatically, and D-BUS autolaunch will start cdemu-daemon user"
+ elog "service."
+}