summaryrefslogtreecommitdiff
path: root/app-cdr/brasero
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /app-cdr/brasero
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'app-cdr/brasero')
-rw-r--r--app-cdr/brasero/Manifest1
-rw-r--r--app-cdr/brasero/brasero-3.12.2-r1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-cdr/brasero/Manifest b/app-cdr/brasero/Manifest
index 15c3d56b5db0..13947b5f1681 100644
--- a/app-cdr/brasero/Manifest
+++ b/app-cdr/brasero/Manifest
@@ -1,3 +1,4 @@
DIST brasero-3.12.2.tar.xz 3742120 BLAKE2B 42cc60d3f4e26e948321c34f2514172aeac5a1b2624e6b23f27cc9725efd5cf0844a54175161b4c94601bbd5c4a6f18ccdd62353e862eddaab17e0d164f4694c SHA512 14886e772123f179f79d3172b59e21ced990fd8834cd27e8717eb635a75163c44c1d5084818b53da559a0c2ef25e7c0da4a3a7d3781e2ea74b59cfe98987384f
+EBUILD brasero-3.12.2-r1.ebuild 1943 BLAKE2B b771b7f2e04ec8a3497ed51b0df37ca60f355ea44157c9b4089f0136a6d9dc1c4463b658feea73b71da9d789c60f61fbea066a9d462e70b1660b166414e6f426 SHA512 77bb1f1614f7484642443c4304828509b7ba30ccb7b521e24ae7638d879472f555ac4be67be375663d95313204a6f6565edadafb3662acf67995b1bb7694f7e8
EBUILD brasero-3.12.2.ebuild 2015 BLAKE2B 0227e0e8b1b99d0c49d492a91bba02b9d51df3cca0896ca6c1d6a39d4d65d57401a3436b90dc9a48c2c42b6c41f4240c840c8733b201e2f7ed2be9639a37a4fb SHA512 c9669c20fd70f869ab1a2fe5eef6924553940e7638a32691cdd5427b472cf3d4272548115c2b71c1efb9b72786658c542760d9ed06c5aee14f9bae7ef0bee9f7
MISC metadata.xml 767 BLAKE2B 731778f406b9adbdf563315ce4e978a567f7c762b2a1659df6ead92cb610fdaf9dffb220ea54988bed0970b9b3cf0330afb390c802627930bbb450e11f8d7db6 SHA512 d5eff95f93edce1d592b2d8b383e04d0f96c92374d8077709d4e8404060e9eefcba9dc16f741651ebb5323f7692b07462ded60c7e6f638be3334fa04740da381
diff --git a/app-cdr/brasero/brasero-3.12.2-r1.ebuild b/app-cdr/brasero/brasero-3.12.2-r1.ebuild
new file mode 100644
index 000000000000..ddad861d80a3
--- /dev/null
+++ b/app-cdr/brasero/brasero-3.12.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD/DVD burning application for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Brasero"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
+IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/libnotify-0.6.1:=
+
+ media-libs/libcanberra[gtk3]
+ x11-libs/libICE
+ x11-libs/libSM
+
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+ libburn? (
+ >=dev-libs/libburn-0.4:=
+ >=dev-libs/libisofs-0.6.4:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.90 )
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
+ tracker? ( >=app-misc/tracker-1:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0[mp3?]
+ x11-themes/hicolor-icon-theme
+ css? ( media-libs/libdvdcss:1.2 )
+ !libburn? (
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ virtual/cdrtools )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.3 )
+"
+# eautoreconf deps
+# app-text/yelp-tools
+# gnome-base/gnome-common
+
+PDEPEND="gnome-base/gvfs"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-caches \
+ $(use_enable !libburn cdrtools) \
+ $(use_enable !libburn cdrkit) \
+ $(use_enable !libburn cdrdao) \
+ $(use_enable !libburn growisofs) \
+ $(use_enable introspection) \
+ $(use_enable libburn libburnia) \
+ $(use_enable nautilus) \
+ $(use_enable playlist) \
+ $(use_enable tracker search)
+}