summaryrefslogtreecommitdiff
path: root/app-benchmarks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
commit70a8e0f526762c28622fae5f944f8f59f9abf728 (patch)
treea58f1b704c29cff0ad8201d20ebbf7a11018f88f /app-benchmarks
parent4eda0fe5576868e6c7f97b51aa1c279ff8cd320c (diff)
gentoo auto-resync : 25:09:2023 - 11:25:16
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/Manifest.gzbin4689 -> 4686 bytes
-rw-r--r--app-benchmarks/pipebench/Manifest2
-rw-r--r--app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch12
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r3.ebuild24
4 files changed, 38 insertions, 0 deletions
diff --git a/app-benchmarks/Manifest.gz b/app-benchmarks/Manifest.gz
index 68f98f7c911a..4a1e2e5713bb 100644
--- a/app-benchmarks/Manifest.gz
+++ b/app-benchmarks/Manifest.gz
Binary files differ
diff --git a/app-benchmarks/pipebench/Manifest b/app-benchmarks/pipebench/Manifest
index dae1595fca7d..73cbf4fc7d8c 100644
--- a/app-benchmarks/pipebench/Manifest
+++ b/app-benchmarks/pipebench/Manifest
@@ -1,4 +1,6 @@
+AUX pipebench-0.40-fix-build-clang16.patch 241 BLAKE2B f1bf0c519d93823a53eccd06e36a9da783ff38a60418d739787023c4fdbab10205fe951f3eb0a6ca48e95284e83fd5883bb88add2844dba176b65fa47937d77f SHA512 f9f12f022672334214f874b7a233b3d32257bd6e402cea5bde71184e05e259b88c7156b56728d178b5f10559efdcfcda5f1724b9350bc1f30658e32dbc1c9595
AUX pipebench-0.40-fix-build-system.patch 603 BLAKE2B 69c90bad81413e22ab1be93014b9a9a8a60207e852354bf74c86aab496761102bdeabebfa1c3d33d803b30d6f42275dfb3c5b2cb9fede394cee9db4b9957a696 SHA512 a054d3393043953c56b759326d0bd72e94233673f945474aaa24fba0c78901997f864e79a255ab282b7251a6d88d6a024c08d332581aa3461bc5ce4be9a94bff
DIST pipebench-0.40.tar.gz 11542 BLAKE2B b024ad8066a0adb2c1c9e1de1de93d9a9e91104380a1d955852b6281f1b4506be3b03240ed238766590c643c1d93060da43c523e773da738adb8bab333894247 SHA512 bace18d73425cf56bc3fd95eea4db47b3010cc82c16d9b433390d0ee4593046ab10101ce73df451596b34ace89fa92e93a92bb625286edb9cdfb809e630788cd
EBUILD pipebench-0.40-r2.ebuild 549 BLAKE2B 2e6ffd0d1886ccf3b9e0276eb2cccd09573d0dcd5009ed713652bae2cde0d47caea58732cccb6ac67c3d7b0636283dfc627f102b65bee47db315a39345ebc1e7 SHA512 1992b32e6be82085f2b951f46fa2b5910abc744954697ecca288b9a8fcb9ebb5ae361fa377421349830353b77772afec32bbbdf58826dc56d44af7ac416edc7e
+EBUILD pipebench-0.40-r3.ebuild 604 BLAKE2B 96db48b4f0c46499deefe4c85956e050e745a91c796672d396feb9817720de7660e0c6ce39575d06071dcc9700c304bbfe10aaa220cd23084333a34182224d0e SHA512 6b606ff4ab3fcd8748fea3c110a1da85ca117c6953cb33b4d46b3353302e389494f27880dc3b85697e66f7b5b5a1fe79d9b8308289e2e5a1c25a30e3fc74c42e
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch
new file mode 100644
index 000000000000..1cc891bd7f08
--- /dev/null
+++ b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/894336
+--- a/pipebench.c
++++ b/pipebench.c
+@@ -28,6 +28,8 @@
+ */
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include <signal.h>
+ #include <sys/time.h>
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild
new file mode 100644
index 000000000000..39367bba594d
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="https://www.habets.pp.se/synscan/programs_pipebench.html"
+SRC_URI="https://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.40-fix-build-system.patch
+ "${FILESDIR}"/${PN}-0.40-fix-build-clang16.patch
+)
+
+src_configure() {
+ append-cflags -Wall -w -pedantic
+ tc-export CC
+}