summaryrefslogtreecommitdiff
path: root/app-benchmarks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 15:37:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 15:37:05 +0100
commit53623081143d09702d8f3d7224e9da8c5f681c3b (patch)
treeaac973d826d9b3dd5281652ca48bce35e5d9c86f /app-benchmarks
parent77f1c17f5328e59f3991203c579fbc85df6898a0 (diff)
gentoo auto-resync : 05:06:2023 - 15:37:05
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/Manifest.gzbin4686 -> 4688 bytes
-rw-r--r--app-benchmarks/stress-ng/Manifest3
-rw-r--r--app-benchmarks/stress-ng/files/stress-ng-0.15.08-fortify-source.patch29
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.15.08-r1.ebuild (renamed from app-benchmarks/stress-ng/stress-ng-0.15.08.ebuild)2
4 files changed, 33 insertions, 1 deletions
diff --git a/app-benchmarks/Manifest.gz b/app-benchmarks/Manifest.gz
index 2e069188826b..6ee8316ce34a 100644
--- a/app-benchmarks/Manifest.gz
+++ b/app-benchmarks/Manifest.gz
Binary files differ
diff --git a/app-benchmarks/stress-ng/Manifest b/app-benchmarks/stress-ng/Manifest
index 264811122964..117c6d4f776d 100644
--- a/app-benchmarks/stress-ng/Manifest
+++ b/app-benchmarks/stress-ng/Manifest
@@ -1,3 +1,4 @@
+AUX stress-ng-0.15.08-fortify-source.patch 987 BLAKE2B 8c970a82df54132c2f5375f8659138209addde95ab5c1f77f6be41b9b4143bc267e3e90e6facf1bc841bb48e005d51b086a72a3fa811fd5dbc69339706e4bf81 SHA512 1df159dea5034270c2047000f7b7a7a3ab77dd39776d0d1b40a0a4903478392e4cf61972e550ec54ad46ca375422af2bbf0c6a0089308b941c9f7f86970fa987
DIST stress-ng-0.15.08.tar.gz 3839684 BLAKE2B 2e2337d26d882abf0c2cdb8451e6fe358c059dd6ab14c3ca13e9da3a83ba29309bdf339a074bc7808a535f8ce892aad09a30cabbec1093b976166e52de6d24ac SHA512 2f5c1ddbe8d2e281bca5b7668a86aebd0836bc9c8023d2553aff4f2216b91cd1c3da9142df5e270c13c4ab7bc6778bc3d699750963107e5f2c127448a3e52298
-EBUILD stress-ng-0.15.08.ebuild 1130 BLAKE2B fc3d5a4923409e94a3055fd018997c32f477dd0e4543adb0fef18a4da066dfb0043ca6805107070aab1cb2804d908aa68c5b2b314a198bf19bfdc18e5fc88ed0 SHA512 1ed861f794c8582f83f17dc353945a821cdba776fd31d0832c26d2d3127026a7d3bb33baaad83d407ef347fc5e1f568c08d4623cb23a9b8ef4892f7975a44fd8
+EBUILD stress-ng-0.15.08-r1.ebuild 1192 BLAKE2B a33427f0f225159cd09dfc11302c25662ae9e1dec89f32da886966ee76dadfbbc2a52c579f2e0c58d5bf775d8ba6bedb858af0882748b0d1596b25715f19c3d7 SHA512 e7780579119686a0e64a93c69ced08b4012b7cbbdb896f77f2e8b347d5b3e0a343ac6da8790cc502ee3f294a6f55beaa10d1751c08e601d9e5e4e64df6488409
MISC metadata.xml 835 BLAKE2B 88b503bcc225861dfd5a5e016bc0c6df87d13e758f9eb8d73103deb5f1d88163f260f24efcb4988a245b1ea2888e18da86d031d52c9dcdc702dbd9a7c510b691 SHA512 dfc8c9cb83e0960fd0881affc5cd12fe843743faa92e3af0edf0ba86ad8107de60669cd32e156be9ea645a817f38f7091be2b9c870902e7109f937e584feac99
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.15.08-fortify-source.patch b/app-benchmarks/stress-ng/files/stress-ng-0.15.08-fortify-source.patch
new file mode 100644
index 000000000000..7b8a75c44766
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/stress-ng-0.15.08-fortify-source.patch
@@ -0,0 +1,29 @@
+From 967f8f4ff467e7d15b7cdf12f3e2f786e5e19375 Mon Sep 17 00:00:00 2001
+From: Colin Ian King <colin.i.king@gmail.com>
+Date: Wed, 31 May 2023 20:15:54 +0100
+Subject: [PATCH] Makefile: always undefine _FORTIFY_SOURCE before defining it
+
+Gentoo seems to define _FORTIFY_SOURCE in the build environment for
+some specific build options and we end up with duplicated define
+warnings. Undefine it before defining it.
+
+Closes https://github.com/ColinIanKing/stress-ng/issues/291
+
+Signed-off-by: Colin Ian King <colin.i.king@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index e08d60ea..693010e1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -59,7 +59,7 @@ CFLAGS += -Werror=format-security
+ endif
+ ifneq ($(findstring pcc,$(CC)),pcc)
+ ifeq ($(shell $(CC) $(CFLAGS) -D_FORTIFY_SOURCE=2 -E -xc /dev/null > /dev/null 2>& 1 && echo 1),1)
+-CFLAGS += -D_FORTIFY_SOURCE=2
++CFLAGS += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+ endif
+ endif
+ endif
diff --git a/app-benchmarks/stress-ng/stress-ng-0.15.08.ebuild b/app-benchmarks/stress-ng/stress-ng-0.15.08-r1.ebuild
index 12a6f5017085..28539472ec24 100644
--- a/app-benchmarks/stress-ng/stress-ng-0.15.08.ebuild
+++ b/app-benchmarks/stress-ng/stress-ng-0.15.08-r1.ebuild
@@ -34,6 +34,8 @@ RDEPEND="${DEPEND}"
DOCS=( "README.md" "README.Android" "TODO" "syscalls.txt" )
+PATCHES=( "${FILESDIR}/${PN}-0.15.08-fortify-source.patch" )
+
pkg_pretend() {
if use apparmor; then
CONFIG_CHECK="SECURITY_APPARMOR"