summaryrefslogtreecommitdiff
path: root/app-benchmarks/stress/stress-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-benchmarks/stress/stress-1.0.5.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-benchmarks/stress/stress-1.0.5.ebuild')
-rw-r--r--app-benchmarks/stress/stress-1.0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-benchmarks/stress/stress-1.0.5.ebuild b/app-benchmarks/stress/stress-1.0.5.ebuild
new file mode 100644
index 000000000000..60a9c7e1e06d
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A deliberately simple workload generator for POSIX systems"
+HOMEPAGE="https://salsa.debian.org/debian/stress"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}