summaryrefslogtreecommitdiff
path: root/app-benchmarks/pipebench
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/pipebench
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/pipebench')
-rw-r--r--app-benchmarks/pipebench/Manifest4
-rw-r--r--app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch21
-rw-r--r--app-benchmarks/pipebench/metadata.xml5
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r2.ebuild22
4 files changed, 52 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/Manifest b/app-benchmarks/pipebench/Manifest
new file mode 100644
index 000000000000..592a09cd8478
--- /dev/null
+++ b/app-benchmarks/pipebench/Manifest
@@ -0,0 +1,4 @@
+AUX pipebench-0.40-fix-build-system.patch 603 BLAKE2B 69c90bad81413e22ab1be93014b9a9a8a60207e852354bf74c86aab496761102bdeabebfa1c3d33d803b30d6f42275dfb3c5b2cb9fede394cee9db4b9957a696 SHA512 a054d3393043953c56b759326d0bd72e94233673f945474aaa24fba0c78901997f864e79a255ab282b7251a6d88d6a024c08d332581aa3461bc5ce4be9a94bff
+DIST pipebench-0.40.tar.gz 11542 BLAKE2B b024ad8066a0adb2c1c9e1de1de93d9a9e91104380a1d955852b6281f1b4506be3b03240ed238766590c643c1d93060da43c523e773da738adb8bab333894247 SHA512 bace18d73425cf56bc3fd95eea4db47b3010cc82c16d9b433390d0ee4593046ab10101ce73df451596b34ace89fa92e93a92bb625286edb9cdfb809e630788cd
+EBUILD pipebench-0.40-r2.ebuild 569 BLAKE2B 1ef74acbacde5f884e6b3d828a83373f3505e0a7f97c737644197cff77d237003da2646dae367886f57f5d7848e14f1c227d8759aa9e77a45e441195e8a3fc51 SHA512 5c651e73ceeb6775183836d31e63f656248ae789649cb6ad36da697093b1822273a4757b32b48424d0cfc395c8789a858d9c6897f4acb172849b8b61726691c1
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch
new file mode 100644
index 000000000000..2d79d80ef7bc
--- /dev/null
+++ b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,16 +1,11 @@
+ # $Id: Makefile,v 1.2 2002/12/15 19:58:36 marvin Exp $
+
+-CC=gcc
+-CFLAGS=-Wall -w -pedantic
+
+ all: pipebench
+ doc: pipebench.1
+ install: pipebench
+- cp pipebench /usr/local/bin/
+- cp pipebench.1 /usr/local/man/man1/
+-
+-pipebench: pipebench.c
+- $(CC) $(CFLAGS) -o pipebench pipebench.c
++ mkdir -p $(DESTDIR)$(EPREFIX)/usr/bin && cp pipebench $(DESTDIR)$(EPREFIX)/usr/bin/
++ mkdir -p $(DESTDIR)$(EPREFIX)/usr/share/man/man1 && cp pipebench.1 $(DESTDIR)$(EPREFIX)/usr/share/man/man1/
+
+ pipebench.1: pipebench.yodl
+ yodl2man -o pipebench.1 pipebench.yodl
diff --git a/app-benchmarks/pipebench/metadata.xml b/app-benchmarks/pipebench/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-benchmarks/pipebench/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
new file mode 100644
index 000000000000..0688bd665cff
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.40-fix-build-system.patch )
+
+src_configure() {
+ append-cflags -Wall -w -pedantic
+ tc-export CC
+}