summaryrefslogtreecommitdiff
path: root/app-benchmarks/os-autoinst
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/os-autoinst
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/os-autoinst')
-rw-r--r--app-benchmarks/os-autoinst/Manifest2
-rw-r--r--app-benchmarks/os-autoinst/metadata.xml4
-rw-r--r--app-benchmarks/os-autoinst/os-autoinst-9999.ebuild41
3 files changed, 47 insertions, 0 deletions
diff --git a/app-benchmarks/os-autoinst/Manifest b/app-benchmarks/os-autoinst/Manifest
new file mode 100644
index 000000000000..67093d5afc5f
--- /dev/null
+++ b/app-benchmarks/os-autoinst/Manifest
@@ -0,0 +1,2 @@
+EBUILD os-autoinst-9999.ebuild 747 BLAKE2B c04a2c5bbd3352c2276f76fe498239d681ec95c50be3c80c9ee53becf18c3515379eae6638bee116ad83f774577e36ef06197d86acc77da4d91b25f0f374652e SHA512 91a7ecafdcf241312fb87c7af2a623daa1b8d184cbf438848f6bd07195773c094b057d27b19573b0117a082b7a18342594b2d2b14815968f5fc9d2c30f0fc8d4
+MISC metadata.xml 139 BLAKE2B b4a59c22790dfec3fbcfaea41ef363401766736b68a85bedae00e1944d0a848aa97104c2f34244c0fe7b6363029281f965fc1b3545301d341cda371eaa976274 SHA512 8be912ace7468a4396eb1da00a9785030a8ce35da4357a01591876a1056fd45e44da65de2af3e1eb0506ce6551714962c40c3ae5a3aefa2ad231de35af2519be
diff --git a/app-benchmarks/os-autoinst/metadata.xml b/app-benchmarks/os-autoinst/metadata.xml
new file mode 100644
index 000000000000..097975e3adc2
--- /dev/null
+++ b/app-benchmarks/os-autoinst/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
new file mode 100644
index 000000000000..f9dca04f3834
--- /dev/null
+++ b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools git-r3
+
+DESCRIPTION="automated testing of Operating Systems"
+HOMEPAGE="http://os-autoinst.org/"
+EGIT_REPO_URI="https://github.com/os-autoinst/os-autoinst.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ media-libs/libogg:=
+ media-libs/libsndfile:=
+ media-libs/libtheora:=
+ >=media-libs/opencv-2.4:=
+ sci-libs/fftw:3.0="
+RDEPEND="${DEPEND}
+ dev-lang/perl[ithreads]
+ dev-perl/JSON
+ app-emulation/qemu
+ app-text/gocr
+ media-gfx/imagemagick
+ media-video/ffmpeg2theora"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}