summaryrefslogtreecommitdiff
path: root/app-benchmarks/os-autoinst
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-benchmarks/os-autoinst
reinit the tree, so we can have metadata
Diffstat (limited to 'app-benchmarks/os-autoinst')
-rw-r--r--app-benchmarks/os-autoinst/Manifest4
-rw-r--r--app-benchmarks/os-autoinst/metadata.xml8
-rw-r--r--app-benchmarks/os-autoinst/os-autoinst-9999.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/app-benchmarks/os-autoinst/Manifest b/app-benchmarks/os-autoinst/Manifest
new file mode 100644
index 000000000000..2dded4e86aa0
--- /dev/null
+++ b/app-benchmarks/os-autoinst/Manifest
@@ -0,0 +1,4 @@
+EBUILD os-autoinst-9999.ebuild 723 SHA256 62e11f2e7079b97c163e2fcd66ca9b05fc4a84bda001afcebb665afccee05c14 SHA512 40aae61c2c6517ad5e48f038285afab920106becdad880e355c821e9417580714470fa44003ba6772a9aa18917428195cd713c886adb924c64224ca3c72e18b5 WHIRLPOOL 38bfd41abd64567aacde132d327ab1547f994fb8b7acf71698ad6a459536d12e4d54cc63b8587620828e294bf99da346fe9ce14dc189cc1028a686ef70a5b105
+MISC ChangeLog 2443 SHA256 55b673e76a15623dd697b626c8f2281615949f078e80d27ba4603a063ba4b73d SHA512 ad0445226203aa9858a49b18e120cf052276e7c012c260df5fdc2d7de8a331ecde3b241ad405ea883308e2c88928bcd9c1f03c922325bdadd530027c5f620d97 WHIRLPOOL ef567dd2d8ad4e8a6e0c4b29ccbbe30ce00a9957b701cb8c265ba7a1f367db4e568dffc54b02d6dd469e89e67f7df14c20325f0cff55acfa8ce7b5a21dbf1165
+MISC ChangeLog-2015 1371 SHA256 f4879de5415b2acc9767941a3b98ee93d574fc45de3181b099653be8e164042f SHA512 657d850cc3df2197848fd2ea48c3abc33ab54b262437add26aa2f14af1aafd15ec953be7ea76ca799702d09884ba9b162a191343e70b0da78ced8f748ff4478d WHIRLPOOL 15f2d4eca4e5c35ea94a8492034f716459d5c2c2c7cbce3c20d29ef3d802c83f6c1a327f31e3b65d7d79d7d9ac8a5a9c465a3608bbb051e06630b7a54125ee04
+MISC metadata.xml 232 SHA256 cae43e94e79a01960721d205a44935817243a3778791d1ba4c8c041c4a9d501b SHA512 23824ca618f16dec558197c0c853f3ebf5c0f1b034635242282bd40f01beea59cbac3b416e86f2eb4337942d9db945a2e1fd4fe52c88762b65749855762769fa WHIRLPOOL 774b24967a2336d4cc213a21ac9c89d0b11c17d626a93badaf1e98dec218db09edc4b73a30e47121a1f1cdd588c7ee9859da00b319d09707b05d802dcb134891
diff --git a/app-benchmarks/os-autoinst/metadata.xml b/app-benchmarks/os-autoinst/metadata.xml
new file mode 100644
index 000000000000..c78052713743
--- /dev/null
+++ b/app-benchmarks/os-autoinst/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>suse@gentoo.org</email>
+ <name>SUSE</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
new file mode 100644
index 000000000000..2f46d77f4b83
--- /dev/null
+++ b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+EGIT_REPO_URI="git://gitorious.org/os-autoinst/os-autoinst.git"
+
+inherit git-2 autotools eutils
+
+DESCRIPTION="automated testing of Operating Systems"
+HOMEPAGE="http://os-autoinst.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=media-libs/opencv-2.4
+"
+RDEPEND="${DEPEND}
+ dev-lang/perl[ithreads]
+ dev-perl/JSON
+ app-emulation/qemu
+ app-text/gocr
+ media-gfx/imagemagick
+ media-video/ffmpeg2theora
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}