summaryrefslogtreecommitdiff
path: root/app-benchmarks/iozone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/iozone
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/iozone')
-rw-r--r--app-benchmarks/iozone/Manifest3
-rw-r--r--app-benchmarks/iozone/iozone-3.471.ebuild74
-rw-r--r--app-benchmarks/iozone/metadata.xml8
3 files changed, 85 insertions, 0 deletions
diff --git a/app-benchmarks/iozone/Manifest b/app-benchmarks/iozone/Manifest
new file mode 100644
index 000000000000..875c7ea02302
--- /dev/null
+++ b/app-benchmarks/iozone/Manifest
@@ -0,0 +1,3 @@
+DIST iozone3_471.tar 1853440 BLAKE2B 280c821a439ad1bacbd749278385481678d644a59c14395482c8a088b0578285f389f376fb32ce3c3abde598f50d693fb0c7c9a3d6597765547a71c76d21ea1c SHA512 c61b2b8b5af3dccdb99b26aef8a0a4f2f5f467fc3985ac72ed4bb4fb36e4b7684ca6dbaa5bbc05ae0a4e73852e048e9fd2495eda9313f5abc4e631499d683aec
+EBUILD iozone-3.471.ebuild 1871 BLAKE2B 5813098f4c6f661dcb8eedea802c0ca13db9de4885c0c484f2882c6a72c8dc442696a83887862621642c2d49f2551c779f3031dfefc871188e1dbc69c4e06834 SHA512 062f87367b305e6a7b9c64ed8692115a42ad529357e61478212bb11b9917ca56f224f3fbaf9727b26c86afd7c7da27079bed737aa01da8c634a7020b8f03264c
+MISC metadata.xml 249 BLAKE2B e266b83580d700efa25e676fca79f0a3e3087e2ac13cd136676205d8c7129532541dee6d30cabf8040283400a70a7fdd305a114820055e092c322284e3e751b6 SHA512 541d74a2d7d079378380eaa4c09743553a6023183d1a7fc52fa527f8463eec32ec277455bf25e809e1f9cddf8a33cef8917e397bd601e9ae2831562c0ce2d6b0
diff --git a/app-benchmarks/iozone/iozone-3.471.ebuild b/app-benchmarks/iozone/iozone-3.471.ebuild
new file mode 100644
index 000000000000..cde87a71ebce
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.471.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# TODO
+# -> linux-arm (32bit) <-
+# -> linux-AMD64 (64bit) <-
+# -> linux-ia64 (64bit) <-
+# -> linux-powerpc (32bit) <-
+# -> linux-powerpc64 (64bit) <-
+# -> linux-S390 (32bit) <-
+# -> linux-S390X (64bit) <-
+#
+# -> freebsd (32bit) <-
+# -> macosx (32bit) <-
+# -> netbsd (32bit) <-
+# -> openbsd (32bit) <-
+# -> openbsd-threads (32bit) <-
+#
+# ~ia64 ~s390 alpha(?) x86-fbsd
+
+inherit toolchain-funcs
+
+DESCRIPTION="Filesystem benchmarking program"
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 arm ia64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}${PV/./_}
+
+src_prepare() {
+ default
+
+ # Options FIX
+ sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
+ -e "s:-O3:${CFLAGS}:g" src/current/makefile || die
+}
+
+src_configure() {
+ case ${ARCH} in
+ x86|alpha) PLATFORM="linux";;
+ arm) PLATFORM="linux-arm";;
+ ppc) PLATFORM="linux-powerpc";;
+ ppc64) PLATFORM="linux-powerpc64";;
+ amd64) PLATFORM="linux-AMD64";;
+ ia64) PLATFORM="linux-ia64";;
+ s390) PLATFORM="linux-S390";;
+ x86-fbsd) PLATFORM="freebsd";;
+ *) PLATFORM="linux-${ARCH}";;
+ esac
+}
+
+src_compile() {
+ emake -C src/current ${PLATFORM}
+}
+
+src_test() {
+ cd "${T}" || die
+ "${S}"/src/current/iozone testfile || die "self test failed"
+}
+
+src_install() {
+ dosbin src/current/{iozone,fileop}
+
+ dodoc docs/I* docs/Run_rules.doc src/current/Changes.txt
+ doman docs/iozone.1
+ cd src/current || die
+ dodoc Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+}
diff --git a/app-benchmarks/iozone/metadata.xml b/app-benchmarks/iozone/metadata.xml
new file mode 100644
index 000000000000..3240f0c89aba
--- /dev/null
+++ b/app-benchmarks/iozone/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+</maintainer>
+</pkgmetadata>