summaryrefslogtreecommitdiff
path: root/app-benchmarks/httperf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/httperf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/httperf')
-rw-r--r--app-benchmarks/httperf/Manifest3
-rw-r--r--app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild37
-rw-r--r--app-benchmarks/httperf/metadata.xml21
3 files changed, 61 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/Manifest b/app-benchmarks/httperf/Manifest
new file mode 100644
index 000000000000..706b7e082dd2
--- /dev/null
+++ b/app-benchmarks/httperf/Manifest
@@ -0,0 +1,3 @@
+DIST httperf-0.9.1_p20161228.tar.gz 106357 BLAKE2B fa35d47a9e59bd8d8979e2a56ef8e5966c8e83a0a738e0995730efb2721344bcfa6187581b04a05ec2ca7f3424072894c7c10dd63cc1a4a2bb4c0f29df2a0a6c SHA512 e5dbb400e4ab0db3cc1621731d99af9261574a8a1da4279c722ebbd80537d0aae2a3d662f4d51eb9130bc98823c2786710c7819a0144f4ae3f8cf153e28d7dfa
+EBUILD httperf-0.9.1_p20161228.ebuild 871 BLAKE2B 82002e03bafc8a3562e681a35a03da189a7320b45fbf8c3957a100ac0652570f78cc8a2451dfcd137cfbbd1955997f96e61215918aea613c696be74bd4349dc1 SHA512 5fde46f6ab920265df114cce8341a772f46e5d9712932eda4e4c5b7593be5f0603fefc08c860d356eb2881656d7f817c0323dbe803e06026d2024077068c10c4
+MISC metadata.xml 1011 BLAKE2B 3254dacb03b6a957106287289566d9aa466768b5449eee054c423f2d22aac5cc464f990a7afa101256cb40075b03404c4af8bee542e6ee01b5af58e7c8a8415b SHA512 86a8ef9ea287532d89d5833abf29d71aae7e9aca494d6e40ebd6f43cb0eb766e63b769bc2218f8e374f13045d2b3445283dac68d384d9fb449e5a0800caf1dfb
diff --git a/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild b/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
new file mode 100644
index 000000000000..a2c8547ee1c9
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+MY_COMMIT_HASH="cc888437e4572ec29a4a7209f34fbd39c31600f5"
+
+DESCRIPTION="A tool from HP for measuring web server performance"
+HOMEPAGE="https://github.com/httperf/httperf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86 ~amd64-linux ~x64-macos"
+IUSE="debug libressl idleconn"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ idleconn? ( dev-libs/libevent:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/usr/bin
+ $(use_enable debug)
+ $(use_enable idleconn)
+ )
+
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-benchmarks/httperf/metadata.xml b/app-benchmarks/httperf/metadata.xml
new file mode 100644
index 000000000000..2f4bf73d81f3
--- /dev/null
+++ b/app-benchmarks/httperf/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">Httperf is a tool for measuring web server
+ performance. It provides a flexible facility for generating various HTTP
+ workloads and for measuring server performance. The focus of httperf is
+ not on implementing one particular benchmark but on providing a robust,
+ high-performance tool that facilitates the construction of both micro-
+ and macro-level benchmarks. The three distinguishing characteristics of
+ httperf are its robustness, which includes the ability to generate and
+ sustain server overload, support for the HTTP/1.1 and SSL protocols, and
+ its extensibility to new workload generators and performance
+ measurements.</longdescription>
+ <use>
+ <flag name="idleconn">Build with the idleconn program</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">httperf/httperf</remote-id>
+ </upstream>
+</pkgmetadata>