summaryrefslogtreecommitdiff
path: root/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild')
-rw-r--r--app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild b/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
new file mode 100644
index 000000000000..a2c8547ee1c9
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.1_p20161228.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+MY_COMMIT_HASH="cc888437e4572ec29a4a7209f34fbd39c31600f5"
+
+DESCRIPTION="A tool from HP for measuring web server performance"
+HOMEPAGE="https://github.com/httperf/httperf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86 ~amd64-linux ~x64-macos"
+IUSE="debug libressl idleconn"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ idleconn? ( dev-libs/libevent:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/usr/bin
+ $(use_enable debug)
+ $(use_enable idleconn)
+ )
+
+ econf "${myeconfargs[@]}"
+}