summaryrefslogtreecommitdiff
path: root/app-benchmarks/geekbench/geekbench-4.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 01:59:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 01:59:31 +0000
commit7b744169f910185aacfd39dbd71d58b58a2e1d2f (patch)
tree1a81b82134de57caaca49c598db383ff87721640 /app-benchmarks/geekbench/geekbench-4.4.4.ebuild
parent330454de22a51b01089472bf131acd28ea0c64ec (diff)
gentoo auto-resync : 15:02:2023 - 01:59:31
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-4.4.4.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-4.4.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-4.4.4.ebuild b/app-benchmarks/geekbench/geekbench-4.4.4.ebuild
new file mode 100644
index 000000000000..cfe8d5583c78
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-4.4.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
+S="${WORKDIR}/Geekbench-${PV}-Linux"
+
+KEYWORDS="-* amd64 x86"
+LICENSE="geekbench"
+SLOT="4"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="
+ opt/geekbench4/geekbench4
+ opt/geekbench4/geekbench_x86_32
+ opt/geekbench4/geekbench_x86_64
+"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto /opt/geekbench4
+ doexe geekbench4 geekbench_x86_32 geekbench_x86_64
+
+ insinto /opt/geekbench4
+ doins geekbench.plar
+
+ dodir /opt/bin
+ dosym ../geekbench4/geekbench4 /opt/bin/geekbench4
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench4 -r <email address> <license key>"
+}