summaryrefslogtreecommitdiff
path: root/app-benchmarks/geekbench/geekbench-4.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /app-benchmarks/geekbench/geekbench-4.3.3.ebuild
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-4.3.3.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-4.3.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-4.3.3.ebuild b/app-benchmarks/geekbench/geekbench-4.3.3.ebuild
new file mode 100644
index 000000000000..e9e4197b56ba
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-4.3.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="geekbench"
+SLOT="4"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="
+ opt/geekbench4/geekbench4
+ opt/geekbench4/geekbench_x86_32
+ opt/geekbench4/geekbench_x86_64
+"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto "/opt/geekbench4"
+ doexe "geekbench4" "geekbench_x86_32" "geekbench_x86_64"
+
+ insinto "/opt/geekbench4"
+ doins "geekbench.plar"
+
+ dodir "/opt/bin"
+ dosym "../geekbench4/geekbench4" "/opt/bin/geekbench4"
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench4 -r <email address> <license key>"
+}