summaryrefslogtreecommitdiff
path: root/app-benchmarks/geekbench/geekbench-3.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /app-benchmarks/geekbench/geekbench-3.4.2.ebuild
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-3.4.2.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-3.4.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-3.4.2.ebuild b/app-benchmarks/geekbench/geekbench-3.4.2.ebuild
new file mode 100644
index 000000000000..2a7e6b95b814
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-3.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.primatelabs.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="geekbench"
+SLOT="3"
+
+RDEPEND="sys-devel/gcc
+ sys-libs/glibc"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/dist/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="opt/geekbench3/geekbench opt/geekbench3/geekbench_x86_32 opt/geekbench3/geekbench_x86_64"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/${PN}3/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto "/opt/geekbench3"
+ doexe "geekbench" "geekbench_x86_32" "geekbench_x86_64"
+
+ insinto "/opt/geekbench3"
+ doins "geekbench.plar"
+
+ dodir "/opt/bin"
+ dosym "../geekbench3/geekbench" "/opt/bin/geekbench3"
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench3 -r <email address> <license key>"
+}