summaryrefslogtreecommitdiff
path: root/app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild b/app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild
new file mode 100644
index 000000000000..1dd285154c72
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-3.4.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com"
+SRC_URI="https://cdn.primatelabs.com/Geekbench-${PV}-Linux.tar.gz"
+S="${WORKDIR}/dist/Geekbench-${PV}-Linux"
+
+KEYWORDS="-* amd64 x86"
+LICENSE="geekbench"
+SLOT="3"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/geekbench3/geekbench opt/geekbench3/geekbench_x86_32 opt/geekbench3/geekbench_x86_64"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/${PN}3/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto /opt/geekbench3
+ doexe geekbench geekbench_x86_32 geekbench_x86_64
+
+ insinto /opt/geekbench3
+ doins geekbench.plar
+
+ dodir /opt/bin
+ dosym ../geekbench3/geekbench /opt/bin/geekbench3
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench3 -r <email address> <license key>"
+}