summaryrefslogtreecommitdiff
path: root/app-benchmarks/cpuburn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/cpuburn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/cpuburn')
-rw-r--r--app-benchmarks/cpuburn/Manifest6
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild31
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild57
-rw-r--r--app-benchmarks/cpuburn/files/01-variables.patch40
-rw-r--r--app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch7
-rw-r--r--app-benchmarks/cpuburn/metadata.xml18
6 files changed, 159 insertions, 0 deletions
diff --git a/app-benchmarks/cpuburn/Manifest b/app-benchmarks/cpuburn/Manifest
new file mode 100644
index 000000000000..d80546c1e1f2
--- /dev/null
+++ b/app-benchmarks/cpuburn/Manifest
@@ -0,0 +1,6 @@
+AUX 01-variables.patch 879 BLAKE2B b1ede6e0c0086caf3b87bd13753a120b47079339aa8d898661119afa2f9c90c4074c2e05e16a5980afcdc31370867b2a72c53d737c7fe66541cb2c8a998bc5e4 SHA512 eef2f5dfc3a49712568001a273be117126beac27560b6e4386e89893ef30acda76c956b96a9a86bf1a0a424003f3eb9214a8a4a1c828fcbbf809eed82a5a7af7
+AUX cpuburn-1.4a-flags.patch 250 BLAKE2B 68e402e16d1b1ce3f278ee580175ddf459993f908e2d8ad1a823b5df619cd0f52b20d2ec56966141ebbd422013b180e4d5602742b3bdb8fec00e87e554dd512e SHA512 6e786ae47148385003529984da314b56918653d36002dcfa10f995a0568703bb269ddb0b4623693e35659415c12ab2ffc641b799389377863b2df0edcc8fe668
+DIST cpuburn-1.4a.tar.gz 9277 BLAKE2B f362380d0f57fd888ee5e5cf8fdf1809ffbc44fc3c3935b64adbd2c29ad0b3f93e5c032fdc265355574625417e7f5f9e9012e6f637c87fe0ae5e2043258f0822 SHA512 db84cabe70af0b6b3579c746f6df08c268b7145c9521fc609ce5b4cfd497dbb0639e52ab55f34110cff297ec23cf1413db28c6bff4e6f81a69722626886df7ce
+EBUILD cpuburn-1.4a-r1.ebuild 719 BLAKE2B 7c9565035030ed64abfba774264d371652b7e43358baef7dcfcfaf2f56ffc2828ccf5d84c28499d3be1f489637fe2883e4649c6b7a6bdafc55bbded0c7601ba6 SHA512 0516ac5c4b275e6a62269827271d321c259894540e558c9f4e15615d7b63496b8e3a75b36d69aeb2bf8558c5903e86381a3b7af64e2c17812e176b35a4fc726a
+EBUILD cpuburn-1.4a-r2.ebuild 1373 BLAKE2B 17b046c45cefc55b3083d4c16776ee68017376f38a9a066104bcc74959744cd490c069f072c10423fc5a29d48f369cbabb1e405b2700523b0868fdacd5b5e299 SHA512 2f98f322e6b5f68ed2212ddc8c92e0976b67c6660d47b48efae1175b6e14a46a75982a1ba3c5bd8874f32451e0d142c31b288d43b3793493b37197c6a8c1275f
+MISC metadata.xml 602 BLAKE2B eda46ae4cc60f92470dc83b419169c6daa3703f32f20a56b5c3764b7eef525a733898322f734739ca3cff379c568ffaa4754f996f5a7fe4637f7c7a3fcd23bf8 SHA512 2c6c59071ca30a6159222e37991b6b3367ba4ac6bc30e583b0ebbf537b9fac007df830fad046bc7904b0aa8e95c6e147fd983c219f97a921e5fd1d40dd593b12
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
new file mode 100644
index 000000000000..3a72f5ced7c5
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${PV/./_}"
+
+DESCRIPTION="Designed to heavily load CPU chips [testing purposes]"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+#SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/01-variables.patch
+ use amd64 && append-flags -m32 #65719
+ tc-export CC
+}
+
+src_install() {
+ dodoc Design README
+ dobin burn{BX,K6,K7,MMX,P5,P6}
+}
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild
new file mode 100644
index 000000000000..db1f520822b5
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="${PV/./_}"
+
+DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading"
+HOMEPAGE="https://downloads.bl4ckb0x.de/pages.sbcglobal.net/redelm/"
+SRC_URI="https://downloads.bl4ckb0x.de/pages.sbcglobal.net/redelm/${PN}_${MY_PV}_tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/01-variables.patch" )
+
+QA_FLAGS_IGNORED="usr/bin/burnBX
+ usr/bin/burnK6
+ usr/bin/burnK7
+ usr/bin/burnMMX
+ usr/bin/burnP5
+ usr/bin/burnP6"
+
+QA_TEXTRELS="${QA_FLAGS_IGNORED}"
+
+src_prepare() {
+ default
+
+ # Respect users compiler and users CFLAGS and LDFLAGS on x86/amd64
+ # Must be always compiled in 32-bit on amd64 arch
+ # See https://bugs.gentoo.org/65719
+ sed -i -e 's/gcc -s/$(CC) $(CFLAGS) -m32 $(LDFLAGS)/' Makefile || die
+
+ # Respect users compiler and users CFLAGS and LDFLAGS on arm
+ sed -i -e '/CC :=/d' -e 's/^.*-mfloat-abi=softfp/ $(CC) $(CFLAGS) -nostdlib $(LDFLAGS)/' ARM/Makefile || die
+}
+
+src_compile() {
+ if use arm; then
+ cd "${S}"/ARM || die
+ fi
+
+ default
+}
+
+src_install() {
+ if use arm; then
+ dobin ARM/burnCortexA8 ARM/burnCortexA9
+ local DOCS=( "ARM/Design" "README" )
+ else
+ dobin burnBX burnK6 burnK7 burnMMX burnP5 burnP6
+ local DOCS=( "Design" "README" )
+ fi
+
+ einstalldocs
+}
diff --git a/app-benchmarks/cpuburn/files/01-variables.patch b/app-benchmarks/cpuburn/files/01-variables.patch
new file mode 100644
index 000000000000..3e8b666c29ec
--- /dev/null
+++ b/app-benchmarks/cpuburn/files/01-variables.patch
@@ -0,0 +1,40 @@
+--- cpuburn-1.4a.orig/burnK7.S
++++ cpuburn-1.4a/burnK7.S
+@@ -74,6 +74,7 @@ int_exit:
+ push %eax
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ .fill 64
+ half: .long 0x7fffffff,0
+--- cpuburn-1.4a.orig/burnP5.S
++++ cpuburn-1.4a/burnP5.S
+@@ -77,6 +77,7 @@ crunch:
+ #else
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0xffffffff,0x3fdfffff
+ one: .long 0xffffffff,0x3fefffff
+--- cpuburn-1.4a.orig/burnP6.S
++++ cpuburn-1.4a/burnP6.S
+@@ -69,6 +69,7 @@ int_exit: # error abort
+ push %eax # *BSD syscall
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e: .long 0xffffffff,0x3fdfffff
+--- cpuburn-1.4a.orig/burnK6.S
++++ cpuburn-1.4a/burnK6.S
+@@ -68,6 +68,7 @@ int_exit:
+ push %eax
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e: .long 0xffffffff,0x3fdfffff
diff --git a/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
new file mode 100644
index 000000000000..97b8836c0af4
--- /dev/null
+++ b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
@@ -0,0 +1,7 @@
+--- Makefile.orig 2001-06-16 05:39:17.000000000 +0200
++++ Makefile 2010-10-12 20:31:38.000000000 +0200
+@@ -1,3 +1,3 @@
+ all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
+ .S:
+- gcc -s -nostdlib -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -nostdlib -o $@ $<
diff --git a/app-benchmarks/cpuburn/metadata.xml b/app-benchmarks/cpuburn/metadata.xml
new file mode 100644
index 000000000000..140c5aa589a6
--- /dev/null
+++ b/app-benchmarks/cpuburn/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ CPU testing utilities in optimized assembler for maximum loading
+ P6 (Intel Pentium Pro/II/III and Celeron TM),
+ AMD K7 (Athlon/Duron/Thunderbird TM),
+ AMD K6, and Intel P5 Pentium chips.
+ </longdescription>
+</pkgmetadata>