summaryrefslogtreecommitdiff
path: root/app-benchmarks/contest/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-benchmarks/contest/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-benchmarks/contest/files')
-rw-r--r--app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch22
-rw-r--r--app-benchmarks/contest/files/contest-fortify_sources.patch11
2 files changed, 33 insertions, 0 deletions
diff --git a/app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch b/app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch
new file mode 100644
index 000000000000..7e8c6b7eb6a2
--- /dev/null
+++ b/app-benchmarks/contest/files/contest-0.61-fix-buildsystem.patch
@@ -0,0 +1,22 @@
+--- contest-0.61/Makefile
++++ contest-0.61/Makefile
+@@ -1,8 +1,8 @@
+ INSTPATH=/usr
+ BIN=$(INSTPATH)/bin
+ MAN=$(INSTPATH)/man
+-CC=gcc
+-CFLAGS= -W -Wall -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations \
++CC?=gcc
++CFLAGS?= -W -Wall -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations \
+ -g -O2
+
+ ifeq ($(shell uname),FreeBSD)
+@@ -14,7 +14,7 @@
+ list_load.o
+
+ contest: $(objs)
+- $(CC) $(CFLAGS) -o $@ $(objs) $(KVM)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(objs) $(KVM)
+ contest.1.gz: contest.1
+ gzip -c contest.1 > contest.1.gz
+ install: contest contest.1.gz
diff --git a/app-benchmarks/contest/files/contest-fortify_sources.patch b/app-benchmarks/contest/files/contest-fortify_sources.patch
new file mode 100644
index 000000000000..042065822612
--- /dev/null
+++ b/app-benchmarks/contest/files/contest-fortify_sources.patch
@@ -0,0 +1,11 @@
+--- contest-0.61/bmark.c 2009-02-27 23:13:44.000000000 +0000
++++ contest-0.61/bmark.c 2009-02-27 23:12:44.000000000 +0000
+@@ -47,7 +47,7 @@
+ }
+ /* child */
+
+- if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC))==-1){
++ if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR))==-1){
+ printsys("Could not open temporary file\n");
+ }
+ if(dup2(tmpfd, TMP_FD)==-1){