summaryrefslogtreecommitdiff
path: root/app-benchmarks/contest/contest-0.61-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/contest/contest-0.61-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/contest/contest-0.61-r1.ebuild')
-rw-r--r--app-benchmarks/contest/contest-0.61-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-benchmarks/contest/contest-0.61-r1.ebuild b/app-benchmarks/contest/contest-0.61-r1.ebuild
new file mode 100644
index 000000000000..a2254a708dd5
--- /dev/null
+++ b/app-benchmarks/contest/contest-0.61-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Test system responsiveness to compare different kernels"
+HOMEPAGE="http://users.tpg.com.au/ckolivas/contest/"
+SRC_URI="http://www.tux.org/pub/kernel/people/ck/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=app-benchmarks/dbench-2.0"
+PATCHES=(
+ "${FILESDIR}/${PN}-fortify_sources.patch"
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare () {
+ # fix #570250 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ tc-export CC
+}
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin contest
+ doman contest.1
+ dodoc README
+}