summaryrefslogtreecommitdiff
path: root/app-benchmarks/bootchart2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-benchmarks/bootchart2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-benchmarks/bootchart2')
-rw-r--r--app-benchmarks/bootchart2/Manifest7
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild78
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.8.ebuild78
-rw-r--r--app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch30
-rw-r--r--app-benchmarks/bootchart2/files/bootchart2.init26
-rw-r--r--app-benchmarks/bootchart2/metadata.xml10
6 files changed, 229 insertions, 0 deletions
diff --git a/app-benchmarks/bootchart2/Manifest b/app-benchmarks/bootchart2/Manifest
new file mode 100644
index 000000000000..7363ee823bb0
--- /dev/null
+++ b/app-benchmarks/bootchart2/Manifest
@@ -0,0 +1,7 @@
+AUX bootchart2-0.14.7-sysmacros.patch 898 BLAKE2B 8529bdfc1a4e554a87673113b91e4a15e2b2f7efe8090eaa0de1b13cfe296cfe74c29f0bd90f05bb4853dd5ef12aff4dc576252004c7977d30e6b2e41592cd52 SHA512 60f703d29e133817439dcbaf7b59d51ae63e98c8fc03ff860f588c6ef3e3aa422c3c5132faf456dde3198f5c02afea9fbdeae43701e4af15de29155fb677dc0a
+AUX bootchart2.init 693 BLAKE2B f91997826a6128f3f496f581d662b3a8c7749f978f442700c9e7f910d0a5d4e62f5f91fac63958f85fcc08f17fcc0710e5553abb36fc0d90f6c70c0191f63b61 SHA512 181ecf9b64c8303ade8544530698a6a217c367927673feaca4d837bb72d13922d47eff9374a482cd225c3189ea80d36ba72ff658aba596f96639f0d1be7a432b
+DIST bootchart2-0.14.7.tar.gz 1175145 BLAKE2B dfe56572eb2f85b68e0ad871c939ef16c48b0ee11ca881f03914d6773b86050091b232d80706f0df1d094c2e069c252609a0266d1cfa5159a6a0916321ea1dcf SHA512 82074a6ca6725a1b9ffe2a5d7f7bc6fd7918ab837573c23f75e7ebf209f30284ac7e59d2e84768ed313e4cee80da8e67dde167881d907fe71eff376ae9d16541
+DIST bootchart2-0.14.8.tar.gz 1175527 BLAKE2B 623ca2269420eda79b09d955ab9d4a37af004e9e97ad0e0c6014e53b4b0c63239661cb5359345306504980b060ccd11488970cb0aa3d832bfb55392724e715dd SHA512 58303db91d22ccc44c0dc765e7a6672fb277840555fd87ce64b8987cba85250cfe3db17f3ec7e0e1e726ad59166a5d3d01a7a262c07b5690c595877b46c66bd0
+EBUILD bootchart2-0.14.7-r1.ebuild 1906 BLAKE2B 25a10d431e40dfe32ea440e4f0684f2747aa8999e96ae1f03a4f31d362191ad103ad675483097e5941336743d80a55931a8c095b4f60e0215492b25698baa31c SHA512 66071bc7926f4be1a14fd6ace9e4690ecc4928b66d949f7bace426b8e3d5caad5b82aaaa1dc1755fca53411fc757e296177b42a5e4d921e4afd5336d0aefa642
+EBUILD bootchart2-0.14.8.ebuild 1917 BLAKE2B 71b125a05233ba635e4173674e16320ddbd3a4c6b4d65945233f19cee6c581be29ed9c3a17f2ca87c87ba9d067ad8de88e4b2e4adae45cb9b563daf4baef6f1b SHA512 007d93ec40b93e8bc4092670802983940aefaa8838950a02dfea7baf5653cf53a3040ecc8c0f00c2e13fc5f2fdc8bff15505eeb227d4a7c75e000f405754607d
+MISC metadata.xml 304 BLAKE2B 171fff1d72aaecb2e11f9d712aae9b40aba252d315f63184036d3757a92843f3e898b7e723b617014bca29b95f928a720ec7115a564766704514e8bc5b826e4a SHA512 a32bf175ccbaf61207413ae249aa66e72c7704abc0e1c41e9a6eb5fbbc21ea143f45588490ef53bbc8a5ffa0145880de87308ed33df9354a1433016f6540f46e
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild
new file mode 100644
index 000000000000..08018cc91c6b
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.7-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit linux-info python-r1 systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="https://github.com/mmeeks/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="svg test X"
+
+REQUIRED_USE="
+ X? ( ${PYTHON_REQUIRED_USE} )
+ test? ( X )"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ X? (
+ dev-python/pycairo[svg(+)?,${PYTHON_USEDEP}]
+ dev-python/pygtk[$(python_gen_usedep 'python2*')]
+ ${PYTHON_DEPS}
+ )
+ sys-apps/lsb-release"
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"/${PN%2}-${PV}
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #579922
+ tc-export CC
+ sed \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
+ -i Makefile || die
+ sed \
+ -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty:g' \
+ -i bootchartd.conf bootchartd.in || die
+}
+
+src_test() {
+ python_foreach_impl emake test
+}
+
+src_install() {
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ installation() {
+ python_domodule pybootchartgui
+
+ python_newscript pybootchartgui.py pybootchartgui
+ }
+ use X && python_foreach_impl installation
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+}
+
+pkg_postinst() {
+ elog "If you are using an initrd during boot"
+ echo
+ elog "please add the init script to your default runlevel"
+ elog "rc-update add bootchart2 default"
+ echo
+}
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.8.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.8.ebuild
new file mode 100644
index 000000000000..d31698dcc3b2
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit linux-info python-r1 systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="https://github.com/mmeeks/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="svg test X"
+
+REQUIRED_USE="
+ X? ( ${PYTHON_REQUIRED_USE} )
+ test? ( X )"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ X? (
+ dev-python/pycairo[svg(+)?,${PYTHON_USEDEP}]
+ dev-python/pygtk[$(python_gen_usedep 'python2*')]
+ ${PYTHON_DEPS}
+ )
+ sys-apps/lsb-release"
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"/${PN%2}-${PV}
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.14.7-sysmacros.patch #579922
+ tc-export CC
+ sed -i \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
+ Makefile || die
+ sed -i \
+ -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty:g' \
+ bootchartd.conf bootchartd.in || die
+}
+
+src_test() {
+ python_foreach_impl emake test
+}
+
+src_install() {
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ installation() {
+ python_domodule pybootchartgui
+
+ python_newscript pybootchartgui.py pybootchartgui
+ }
+ use X && python_foreach_impl installation
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+}
+
+pkg_postinst() {
+ elog "If you are using an initrd during boot"
+ echo
+ elog "please add the init script to your default runlevel"
+ elog "rc-update add bootchart2 default"
+ echo
+}
diff --git a/app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch b/app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch
new file mode 100644
index 000000000000..48cf685c0ca6
--- /dev/null
+++ b/app-benchmarks/bootchart2/files/bootchart2-0.14.7-sysmacros.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/579922
+https://github.com/xrmx/bootchart/commit/add58c3b57064afd6f7d2fd5f09006d28a3e770e
+
+From add58c3b57064afd6f7d2fd5f09006d28a3e770e Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 21 Apr 2016 00:19:32 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev
+
+These funcs are defined in the sys/sysmacros.h header, not sys/types.h.
+Linux C libraries are updating to drop the implicit include, so we need
+to include it explicitly.
+---
+ collector/collector.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/collector/collector.c b/collector/collector.c
+index cfdcb26..2f3ce6b 100644
+--- a/collector/collector.c
++++ b/collector/collector.c
+@@ -33,6 +33,7 @@
+ #include "common.h"
+
+ #include <sys/mount.h>
++#include <sys/sysmacros.h>
+ #include <linux/fs.h>
+ #include <linux/genetlink.h>
+ #include <linux/taskstats.h>
+--
+2.7.4
+
diff --git a/app-benchmarks/bootchart2/files/bootchart2.init b/app-benchmarks/bootchart2/files/bootchart2.init
new file mode 100644
index 000000000000..3e5d968c0376
--- /dev/null
+++ b/app-benchmarks/bootchart2/files/bootchart2.init
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use localmount
+}
+
+start() {
+ if /bin/grep -q "rdinitrd=/sbin/bootchartd" /proc/cmdline; then
+ if /bin/pidof bootchart-collector> /dev/null 2>&1; then
+ ebegin "Scheduling termination of Bootchart"
+ /sbin/bootchartd start
+ /sbin/bootchartd wait &
+ eend $?
+ fi
+ else
+ einfo "No bootchart process found!"
+ eindent
+ einfo "This script does not start bootchart, but only schedules its termination."
+ einfo "Bootchart should be started from the kernel command line."
+ einfo "Please check the README on how to do that."
+ eoutdent
+ eend 0
+ fi
+}
diff --git a/app-benchmarks/bootchart2/metadata.xml b/app-benchmarks/bootchart2/metadata.xml
new file mode 100644
index 000000000000..59b22aee67c9
--- /dev/null
+++ b/app-benchmarks/bootchart2/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mmeeks/bootchart</remote-id>
+ </upstream>
+</pkgmetadata>