summaryrefslogtreecommitdiff
path: root/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-benchmarks/bashmark/bashmark-0.6.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-benchmarks/bashmark/bashmark-0.6.2.ebuild')
-rw-r--r--app-benchmarks/bashmark/bashmark-0.6.2.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
index c50dd20f0339..6b8964a76be9 100644
--- a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
+++ b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils
+inherit toolchain-funcs
DESCRIPTION="Geno's cross platform benchmarking suite"
HOMEPAGE="http://bashmark.coders-net.de"
-
SRC_URI="http://bashmark.coders-net.de/download/src/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-gcc47.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+)
+
+src_configure() {
+ tc-export CXX
+
+ default
}
src_install() {