summaryrefslogtreecommitdiff
path: root/app-backup/vzdump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/vzdump
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/vzdump')
-rw-r--r--app-backup/vzdump/Manifest3
-rw-r--r--app-backup/vzdump/metadata.xml12
-rw-r--r--app-backup/vzdump/vzdump-1.2.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/app-backup/vzdump/Manifest b/app-backup/vzdump/Manifest
new file mode 100644
index 000000000000..2baf74810601
--- /dev/null
+++ b/app-backup/vzdump/Manifest
@@ -0,0 +1,3 @@
+DIST vzdump-1.2.tar.gz 20296 BLAKE2B adbf4c8a51b9d87f022f6c415db566b5df41c33ca6fca800f362d4eb6b25de53bcc7106b54790e59fe22091e9b519d467750e20e467656ed0ec6d9ac90e66ff4 SHA512 c24bf785704ca3a624127b322a87fee5436fa272e42db159bd08b575405a9ec427d9ad3c82bb0a839495ece4f53b7dafcadc0430b8074368bb8cd844eb31b6cc
+EBUILD vzdump-1.2.ebuild 706 BLAKE2B 6d3b82ae5921b0675a49fb9ca9b045113b3bc2e8c67dfc9006b1e7f00f765bcb8c4121afd8f51e22cb1eebfa8075cba7e9245cc3be14a8133ed8b23444d7fa47 SHA512 0e54a475a22da82b4981f4151bc977e12cffc8a641a0c24fba8eff26f4576e386a8892ea6f40d43503750376842fa4284122a5510f3377fcf98959dac5c8aff6
+MISC metadata.xml 576 BLAKE2B 0b8dd9f78be1968ca2bfd9c7575929d62e58a1d2da883d7c9f7a349512b0b2c727e453b06ea7c7a3e962c3a5bcc01814a3f5414c43fbba54462259fae810bb2d SHA512 fb26f6fd4b243369db5d037e3027d197150e10e81eccc41880638c5454b822aaf9f2f78c8719cfc6eec4150c0ed7ce7e06438950b2d5a72f9b807bd42199ed4a
diff --git a/app-backup/vzdump/metadata.xml b/app-backup/vzdump/metadata.xml
new file mode 100644
index 000000000000..da366eec9b75
--- /dev/null
+++ b/app-backup/vzdump/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ vzdump is a utility to make consistent snapshots of running OpenVZ VEs. It basically creates a tar archive of the VE private area, which also includes the VE configuration files.
+ There are several ways to provide consistency:
+ - stop the VE during backup (very long downtime)
+ - use rsync and suspend/resume (minimal downtime)
+ - use LVM2 (no downtime)
+ </longdescription>
+</pkgmetadata>
diff --git a/app-backup/vzdump/vzdump-1.2.ebuild b/app-backup/vzdump/vzdump-1.2.ebuild
new file mode 100644
index 000000000000..7027a1cd9fe0
--- /dev/null
+++ b/app-backup/vzdump/vzdump-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-functions
+
+DESCRIPTION="A utility to make consistent snapshots of running OpenVZ containers"
+HOMEPAGE="http://pve.proxmox.com/wiki/VZDump"
+SRC_URI="http://www.proxmox.com/cms_proxmox/cms/upload/vzdump/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-lang/perl:="
+RDEPEND="${DEPEND}
+ app-misc/cstream
+ dev-perl/LockFile-Simple
+ net-misc/rsync
+ sys-cluster/vzctl
+ sys-fs/lvm2
+ virtual/mta
+ virtual/perl-Getopt-Long"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake PERLLIBDIR="$(perl_get_vendorlib)/PVE" DESTDIR="${D}" install
+ einstalldocs
+}