summaryrefslogtreecommitdiff
path: root/app-backup/spideroak-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-10 06:08:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-10 06:08:39 +0100
commitdd14643cac4a1aa6ce4151cea5c424577434968b (patch)
tree18bf4bedb3567cde89b92498471a0de3b09c5f78 /app-backup/spideroak-bin
parent024d1b6f101ade7073320fba887d4808c933a8e8 (diff)
gentoo auto-resync : 10:10:2023 - 06:08:39
Diffstat (limited to 'app-backup/spideroak-bin')
-rw-r--r--app-backup/spideroak-bin/Manifest1
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-7.5.0-r3.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index 75354910e43d..2c0ff2112fcb 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -1,4 +1,5 @@
DIST spideroak-bin-7.5.0_amd64.deb 20758038 BLAKE2B ecd549ee0d479f576e8d50b44f4f7a13c4d24445af32f460d34081e5b654586f314399b34cff1c937e157582a143fee6b98641a68655552bb6d3609e532ceba4 SHA512 4af9f6b57d8748c03bccb0ab843cf27f70eac8e8cc5f11bb494c597d5fd29f475bf9c68bce8971d3cc1550a6def7bac6beed78fdfb31961b09be61ee14116ddd
DIST spideroak-bin-7.5.0_x86.deb 24779422 BLAKE2B 8cdae243794e5de6a8326e335b539d004c0ba0f1121b85067acbffffbef67f4a0c785f3b794abb62a5eedfd459c8e4d5e48cf8848b005ba637150b286b13db22 SHA512 32504b6e6931f1e923d4202f0b3201c93190128d30767ec41ac11cf7c8c751b87094bdedcf44dda3ae8089543418366c5a78093b9236fee5f95e7f89a29141fc
EBUILD spideroak-bin-7.5.0-r2.ebuild 2784 BLAKE2B f7a188186935ae51396242a659b6fc95a5d1b764f7f5d46dc9358599a93003afc15917cace104af2600c6e839296becfeea5af8ccb8ca82850741c7f60c9e3a8 SHA512 63eeeb2a65dc67cd785e9e206225e0a07de78bd5786597d8e538b6f8b43518b2aee8f950a6a41fda2edebe6758eb0d9c61af7012b29a20d9e08c0859e5ccf60a
+EBUILD spideroak-bin-7.5.0-r3.ebuild 2717 BLAKE2B 7aa00fa05fe74167b0b9ef2749a8ff66d5957a726fe61dc410acb051db20282b04e83b47a961f5a290cacb9b3c50209043584642231b399304ee0ac5adfcfa5a SHA512 895a599cc8c8a5658deb8888a96c6088dcbc5a4b7fa68d8b7242d3ad38a3e011aee388bb5d1fc968192ff332638225e8240ae020c20d639a25b5f455f868304c
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-backup/spideroak-bin/spideroak-bin-7.5.0-r3.ebuild b/app-backup/spideroak-bin/spideroak-bin-7.5.0-r3.ebuild
new file mode 100644
index 000000000000..d5e18a928843
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-7.5.0-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop prefix unpacker
+
+DESCRIPTION="Secure free online backup, storage, and sharing system"
+HOMEPAGE="https://spideroak.com"
+
+SRC_URI_BASE="https://spideroak.com/release/spideroak"
+SRC_URI="
+ x86? ( ${SRC_URI_BASE}/deb_x86 -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}/deb_x64 -> ${P}_amd64.deb )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+BDEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ media-libs/libpng-compat:1.2
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in $(find) ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ # Remove the libraries that break compatibility in modern systems
+ # SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6" || die
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1" || die
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0" || die
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1" || die
+
+ eapply_user
+}
+
+src_install() {
+ hprefixify usr/bin/SpiderOakONE
+
+ # Install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ # Install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher} || die
+
+ # Install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ insinto /
+ doins -r etc
+
+ # Install the manpage
+ gzip -d usr/share/man/man1/SpiderOakONE.1.gz || die
+ doman usr/share/man/man1/SpiderOakONE.1
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}